0

First a bit of backstory. I'm working at a small business that runs their own web/mail/file server. The server is running on Debian lenny and I have been trying to update it, I ran into a problem with dovecot not starting so decided to reboot the entire server, bad idea.

Now to the problem. When the server restarted it got to bios fine then came to a black screen with just a cursor flashing in the top left corner, nothing will get it past this screen, accompanying this screen is a constant beep (similar to post but constant). This occurs when booting to the default drive, if I select another of the drives using bios it gets to the grub rescue shell.

I have tried to solve this issue by booting into a linux live usb and reinstalling the bootloader but i'm new to the sys admin game and unsure of what steps to take to repair the grub (if the problem even stems from the grub).

Extra notes:

There are 3 drives in raid 1, each with two partitions.

I can mount the system using mdadm --assemble

From the mounted system i can view information on the boot partition

Thanks for any help/advice provided!

EDIT: Some more info

There are 3 drives(that appear in gparted) and 4 in the server machine itself. sdb is 500GB with two partitions and ext3 partition with grub inside and a linux raid partition.

sdc and sdd are both 2TB hard drives and both contain a linux swap partition and a ext3 partition, they appear to mirror each other.

After using mdadm --assemble --scan I have 4 new partition md1, md2, md126 and md127. md1 looks like a copy of the sdb grub partition, md2 looks like a cop of the linux-raid partition on sdb but it is unallocated. md126 is the data partitions from sdc and sdd and md127 is the swap paatition.

  • 1
    Are you sure it's RAID 1? It typically requires an even number of disks to work properly... – Nathan C May 8 '14 at 12:05
  • There are 4 disks in the server but only 3 of them appear in gparted, I don't know much about RAID so this is possibly a case of a dead HDD. The only thing is the server had been running fine for over a year and it seems unlikely for a disk to die when I go for a restart, unless the system can handle a disk dying. – Seize the Cheese May 8 '14 at 18:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.