I work on a standalone network that has 3 domain controllers all running Server 2008 r2. Two of the servers are physical (DC1 / DC2) and one is virtual (DC3).

I want all my systems to refer to DC1 as the time server and I want DC1 to refer to itself. DC1 cannot connect to the internet so I simply want to use its local cmos clock.

Using w32tm commands on DC1 or changing the registry, how can I do this? At the moment DC1 is setting its clock to the time on DC3 (the vm) and DC3 is setting its clock to DC1.

I can find plenty of instruction on how to set the clock to a different server, but none on how to set the clock to the server it is on. Can I use as the target IP address with w32tm /config?

I don't want my domain controllers to get out of sync!

  • I read somewhere that when a server doesn't have any other time servers to sync to, it'll fall back to its hardware clock. But I'm not sure and you should do some tests with that. – user186340 May 7 '14 at 21:03
  • Andre, thanks! I have 3 domain controllers, each of which has the ability to act as a time server. I just need one of them to target itself instead of the other servers. – Shrout1 May 8 '14 at 12:28

This wasn't exactly hard to find on the Microsoft Support site, as such the below is an exact copy and paste from here.

There are two ways to go about this, the first is using the "Fix it for me!" executable that Microsoft provide, and the second is the "Fix it myself!" methods as mentioned below.

To configure the PDC master without using an external time source, change the announce flag on the PDC master. The PDC master is the server that holds the forest root PDC master role for the domain. This configuration forces the PDC master to announce itself as a reliable time source and uses the built-in complementary metal oxide semiconductor (CMOS) clock. To configure the PDC master by using an internal hardware clock, follow these steps:

  • Click Start, click Run, type regedit, and then click OK.

  • Locate and then click the following registry subkey:

  • In the right-pane, right-click AnnounceFlags, and then click Modify.

  • In Edit DWORD Value, type A in the Value data box, and then click OK.

  • Close Registry Editor.

  • At the command prompt, type the following command to restart the Windows Time service, and then press Enter:

    net stop w32time && net start w32time

  • Any particular reason that the AnnounceFlags key wouldn't be in my registry? Checked the location listed in the article and searched the registry. – Shrout1 May 8 '14 at 12:27
  • Are looking on the PDCe FSMO role holder? – mfinni May 8 '14 at 19:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.