Today while I was booting I got an error in an ext4 partition with some inodes. I just entered the root password and run fsck manually but I am a bit worried. fsck warned many times about some errors with inodes and asked me if I wanted to clear them one by one and I said yes but I am wondering if I have incurred in data loss, how can i check it?

Also the previous shutdown was normal and I have 60GB of free space so I don't know what could have caused it, any ideas?

  • Did you run the fsck on the root partition while the OS was running?
    – MadHatter
    May 12, 2014 at 13:35
  • No, it was in the /home partition. The OS was running, yes.
    – Javier
    May 13, 2014 at 10:07
  • And the partition was mounted at the time of the fsck?
    – MadHatter
    May 13, 2014 at 10:19
  • Well I got dropped to a shell(like emergency mode) and then tried when I tried to run fsck it told me that the partition was monted so I had to unmount it and run fsck.
    – Javier
    May 14, 2014 at 23:05
  • OK, then you haven't made any of the usual errors - well done! Is this a virtual or physical machine?
    – MadHatter
    May 15, 2014 at 14:41

1 Answer 1


Sometimes you have to just shrug, and for me this is one of those times.

File systems do get corrupted (obscure kernel bugs, subtle hardware incompatibilities, cosmic ray events (yes, really), bad/noisy cabling) and from time to time you really do have to quiesce a system and fsck the filesystems, just to make sure no such error has happened, or if it has, to tidy up (once a file system gets corrupt, ongoing operation tends to further corrupt it).

How can you know if you lost data? If your backup software allows you to verify the online storage against the last good backup, that can provide a handy check for whether a big chunk of the FS has disappeared. Systems like tripwire can help, but you need to have had them set up and running already, and in any case it would be odd to run such a thing against the /home partition. By all means take a look in /home/lost+found, since any detached content will have been reconnected there by the fsck.

If none of that turns anything up, then set a mental flag about "I need to fsck these file systems more often" and maybe "I don't entirely trust that hardware", and move on.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .