1

I have been given a VM in Windows Azure with Windows Server 2008 R2/ IIS 8.0 running. It has a default website. Now I wanted to create a dev version of that site at some other port, say 81. I added that application and added inbound rule in the firewall for tcp port 81.

Now I can browse the site on that machine using http://localhost:81, but externally I am unable to browse or connect. For the site I used binding to

http - Any unassigned IP - Port 81 - (hostname left blank)

Here is the fiddler response

[Fiddler] The connection to 'originaldomainname' failed. Error: TimedOut (0x274c). System.Net.Sockets.SocketException A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond XXX.XX.XXX.XX:81

What can I do to troubleshoot the connection. Is the ISP blocking that port's traffic? Originally I tried to do that on port 8080 but that had the same problem

Edit
When I do netstat -ano | find ":81" I get this

TCP 0.0.0.0:81 0.0.0.0:0 LISTENING 4
TCP [::]:81 [::]:0 LISTENING 4

How can I make an entry here? with the public ip as foreign address and private ip as local one.

  • Check your windows firewall, maybe it blocking connection from outside, but not from localhost – masegaloeh May 13 '14 at 7:23
  • that is actually I want to ask. How can I check it? – bilal.haider May 13 '14 at 7:24
  • I tried adding a rule to allow outbound traffic for remote port 81. But it didn't affect anything – bilal.haider May 13 '14 at 7:25
  • Try open your port 81 for inbound and outbound connection. – masegaloeh May 13 '14 at 7:26
  • That has not changed anything, how can I diagnose where is the problem in connection. I guess my IIS and VM have the correct settings – bilal.haider May 13 '14 at 7:31
2

There are 2 things you have to do for this to work on a VM on Azure.

Windows Firewall

Make sure you have a firewall rule that allows connection over TCP to port 81. It should look like this

enter image description here

Azure Firewall

In Azure portal, go to your VM. Then click on the endpoints tab and add a rule for port 81 as well

it should look like this

enter image description here

  • thanks, I didn't know about the azure management portal, nor do I have access to it, but that would certainly fix the problem. Thank you – bilal.haider May 15 '14 at 5:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.