1

hi there how can I be sure that ffmpeg is install in my server...

I tried this php code to check:

<?php

    $ffmpeg = trim(shell_exec('which ffmpeg')); // or better yet:
$ffmpeg = trim(shell_exec('type -P ffmpeg'));

    if (empty($ffmpeg))
{
    die('ffmpeg not available');
}

shell_exec($ffmpeg . ' -i ...');?>

It return me 'ffmpeg not available' but my server admin tell me it is install!

I have access also centos consol

closed as off-topic by Iain, mdpc, MichelZ, Tom O'Connor May 14 '14 at 9:58

This question appears to be off-topic. The users who voted to close gave these specific reasons:

  • "Questions must demonstrate a minimal understanding of the problem being solved. Try including attempted solutions, why they didn't work, and the expected results. See How can I ask better questions on Server Fault? for further guidance." – Iain, Tom O'Connor
  • "Questions must be relevant to professional system administration. Server Fault is dedicated to professional system and network administrators. End user and enthusiast questions are off-topic (contact your system administrator or hire a professional to help you out). Please see the Help Center for more information." – mdpc, MichelZ
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Ask your server admin what the path to ffmpeg is then use that. – Iain May 13 '14 at 18:29
2

Did you try using the following command,

ffmpeg -version

The above command should show you the FFMPEG Version information if Installed.

Not the answer you're looking for? Browse other questions tagged or ask your own question.