5

Hello serverfault community, and thank you in advance for your time.

Summary: I have an IBM x3650, which I bought secondhand (eBay). I am trying to install and run VMWare ESXi 5.5 on it via a USB flash drive, but it will not boot from a USB flash drive. It simply does not give me option anywhere to boot from a USB device.

Details: I have turned on the USB-related option in the BIOS. I have visited the F12 boot device menu, and there is no USB option. I have booted from the ESXi installer CD, which was able to identify both of the flash drives I plugged in, but only after I pulled them out and plugged them back in. The device summary in the BIOS recognizes my mouse and keyboard in any port, but never sees any other connected USB devices.

Models, versions, etc: Server chassis identifies itself as a 797961U, but motherboard is different from the one in IBM's 7979 User Manual. It is running BIOS v1.19 (latest that I can find). I have tried a Kingston Datatraveler and Sandisk Cruzer Fit. I have tried all 6 external USB ports. There is no internal USB port on this model.

Question: Has anyone else had this issue? Is there a way of tackling this that I haven't considered? Do I have any recourse through IBM with a secondhand server?

7

Reading regarding this on IBM support forums the suggestions to get it working are:

  1. Make sure you have latest Bios Ver.
  2. Make sure you have USB options selected in BIOS
  3. Insert USB and boot server
  4. Select F12 (Boot options) during boot up.
  5. USB will be displayed, select it and you will be prompted if you want to make it "Persistent" Boot.

People report that Sandsik Cruzer's and some other USB's just seem to not work. So try different USB devices with F12 option.

SanDisk Cruzer does not work. I tried some others which did not work either despite doing everything described in various forums. I went and bought a Imation for a few dollars and it worked perfectly for ESXi 5.1 as described in the forums.

Source: https://www.ibm.com/developerworks/community/forums/html/topic?id=77777777-0000-0000-0000-000014877599

It seems you already have latest BIOS and you have mentioned enabling USB in BIOS, so I would try different USB sticks, even the cheaper ones you have around just to see if you can get it working.

  • Since I have not spun up a server from bare metal before, I just want to be clear: the implication here is that the BIOS cannot see the drive I'm working with, but a compatible drive will be visible and cause the USB boot option to appear? – YouAreTheHat May 13 '14 at 20:41
  • Yes you should see 'USB Drive'. Also, when you will choose it, it will ask you if you want to set it as a permanent boot media (which you should do if you want VMWare ESXi to boot again from USB flash if you reboot). – phoops May 13 '14 at 21:02
0

This is tried with images of Proxmox 5, Ubuntu Server 16.04 and CentOS 7.

Change /dev/sd# accordingly.

dd if=/path/to/os.iso of=/dev/sd# bs=4M

fdisk /dev/sd#

For every EFI or GPT partition type on the usb, change to W95 FAT32.

t
<partition number>
b

Make sure first partition has boot flag, toogle if not.

a 
1

Then write changes, and sync before unplugging.

w
sync

Boot with the usb in port 1 on the rear end off the IBM x3650.

Press F12 when asked.

0

I have an IBM x3650 (7979) and had similar issues installing FreeNAS 11.1 using SanDisk stick (Glide 16GB, which however worked great on my other systems using Supermicro boards). I booted the installation CD through X3650's builtin CD-ROM drive, and the installation saw the Cruzer stick, but process always failed with bunch of write errors to the USB drive. I finally overcame the problem using an old Kingston 32GB USB 2.0 stick (couple of years old), and the install went through without any issue. After the installation, I set the BIOS to boot from USB (F12 option, then select USB Drive, then make it "Persist").

The built-in ServeRaid-8K controller does not have native ZFS support, so I installed a low-profile LSI SAS HBA controller (HP variant of LSI SAS3442E-R, flashed to LSI IT mode) . I am so happy to bring this serve alive with FreeNAS!

-1

I was testing out free esxi on a x3650 (7979) and I was able to get it to boot off an old 32Gb corsair voyager USB just fine. I wanted to free it up, so I bought a sandisk cruzer because I heard they are good performers, but I could not boot up off the sandisk. So I guess it depends on the USB stick as to whether the x3650 will see it or not.

-1

Use unetbootin to create the USB... I'm using SanDisk Cruzers to boot the installation image right now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.