1

I was previously using another firewall software and simply by port forwarding port 1723 from the ADSL interface to a Windows Server attached to the LAN, we were able to VPN in. Since switching to Pfsense we are unable to VPN.

Lan Ip: 172.26.0.1 VPN Server Ip = 172.26.0.50

ADSL interface Router IP 192.168.2.253 In the router we DMZ everything to 192.168.2.11 which is the IP of the ADSL interface (192.168.2.253 being the gateway). We then add the rules in NAT to allow for SSH access etc. Other rules applied to this interface are working correctly.

However, the VPN is not working correctly. The usual screen appears, but gets stuck on verifying username and password. After a while I get error 806.

It mentions about GRE in the error message and I can see this in Pfsense in the Assign section of interfaces an option to add GRE, however, I am unsure exactly what details I need to supply here.

Here a some of my settings including NAT rules.

I currently have the Pfsense PPTP disabled.

Anyone help or info would be much appreciated.

  • For anyone reading I still have the issue, but have set up the pfsense PPTP VPN instead. I now have this working but can connect via a PC not an iphone though. Another issue! – The Humble Rat May 19 '14 at 8:54
  • You should try switching to using OpenVPN under pfSense. it's relatively easy to setup and it will work when tethered via your iPhone, etc. Also it is a lot more secure the PPTP – tegbains Jun 3 '14 at 6:36
2

I found that you can just use the redirect option to your VPN server(e.g. 10.81.48.1 in VPN:PPTP confirguation)

| improve this answer | |
  • Many thanks for your answer, it may not surprise you that I ended up going a different route, it would be a sad day if I had been waiting for my inbox to flash up for 15 Months. I never did solve this and I would love to see if your solution works. For now though I don't see any others answers to this question appearing in the next year, so as far as I am concerned, the points go to you. Thank you for taking the time! – The Humble Rat Aug 27 '15 at 14:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.