0

Following are set and confirmed:

  • I've set $cfg['Servers'][$i]['LoginCookieValidity'] = 259200; in config.inc.php,
  • I've set session.gc_maxlifetime = 259200 in php.ini,
  • I see value 259200 in Settings > Features > General tab, in Login cookie validity field, in phpMyAdmin.

And even so, my phpMyAdmin logs-off automatically, with message, that there was no action for past 1440 seconds (default pMA's value) and re-login is required. So, it still ignores my setting of 259200 seconds (three days).

What other settings or factors may influence this behavior?

EDIT: I'm using XAMPP for Windows, and I've observed this behavior only on one of my computers, though I'm using exactly the same settings set (entire XAMPP unpacked from common .zip file) on my every machine (other computers keeps pMA session for 3 days. This makes case even more suspicious.

  • 1
    While you change cookie settings I don't think your phpMyAdmin is set to use them and is still using session instead. – phoops May 18 '14 at 12:40
  • @edvinas.me Are you talking about $cfg['Servers'][$i]['auth_type'] param? It is set to 'cookie' in my case, so I think, my pMA IS using cookies. – trejder May 18 '14 at 12:47
  • 1
    Did you restart apache, not mysqld? – symlynk May 18 '14 at 19:07
  • @symlynk Of course! :] – trejder May 19 '14 at 7:42
0

For those, struggling the same problem.

The LoginCookieValidity is system-wide setting, not per-server one. So it have to be specified as $cfg['LoginCookieValidity'], not as $cfg['Servers'][$i]['LoginCookieValidity'].

Plus, standard cases, mentioned by edvinas.me and symlynk in the comments: make sure, that you set phpMyAdmin to use cookies ($cfg['Servers'][$i]['auth_type'] param set to cookie) and that you restart Apache after all the changes to configruation files are saved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.