3

I have an IBM IntelliStation Z Pro (except model unknown) with a Rosewill RC-201 RAID controller. When trying to install Windows Server 2008 R2 x64 the installation begins, I select the drivers, and the install continues, however when it reboots as it normally would, it goes to the "Repair Windows Installation" screen and if one selects "Start Windows Normally" it simply reboots the machine.

This machine had Server 2008 R2 x64 on it previously, however after it was demoted as a Domain Controller it began having serious issues, so I opted to reinstall Windows.

The only difference between the original install and now is that the IDE DVD drive built into the machine won't boot from a disk anymore, so I had to hook up a SATA drive. This required me to enable the SATA controller on the board, which was previously disabled -- I also set the Native Mode as both Serial ATA and also tried Parallel ATA, if set to "auto" it doesn't work at all. I am curious if this has anything to do with it, however if I disable the SATA controller after install, it still fails to start, having the same issue as listed above. There were no other hardware changes.

Other than the start up repair screen, there are no errors, warnings, or anything else that would give a sign as to what to do. If one actually runs the repair, it does run and essentially says "if the repaired worked, Windows will boot fine" and it's the same issue.

2

After a lot of messing around I confirmed that it was the fact that two different SATA/RAID controllers were enabled. Even though one was on the board and one was a card, after install it seemed as though Windows was simply confused and couldn't deal with it. I wanted to be certain it was Windows and not my hardware, so I installed Ubuntu and it worked perfectly with both enabled.

Initially the solution seemed to be to disable the on-board SATA and use a thumb drive to install Windows, however this didn't work either, because after reboot there would simply be a blinking cursor and the operating system would never load.

So, my solution may be a case solution, but just in case it is useful to anyone else, here is what I did:

  • I made an ISO of my install DVD on another machine and used Rufus to put it on my thumb drive.
  • Since I only had one thumb drive, and slip streaming wasn't an option, I created a "drivers" directory on it where I put my RAID drivers.
  • The BIOS forces me to treat the thumb drive as a hard drive not a "removable device" so I plugged it in before booting and set it to boot first
  • After booting the installer, selecting my drivers, etc I had to delete all partitions and select the unpartitioned space, if I tried to create partitions or format, it would say the partition was unavailable for install.
  • When setup was ready to reboot, I unplugged the thumb drive before POST, but did not change any BIOS settings
  • When the installer would come back up to complete, I plugged the thumb drive back in and it finished without issue

It was confusing and cryptic, but it worked. I hope this will save someone time in the future, especially the parts about needing to unplug the thumb drive and also not creating partitions, just letting the Installer do everything.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.