1

I try to install PHP5-DOM on CentOS 6.5 using yum install php-xml and get this error:

Error: Package: php-xml-5.3.3-27.el6_5.x86_64 (updates)
  Requires:  php-common(x86-64) = 5.3.3-27.el6_5
  Installed: php-common-5.4.28-1.el6.remi.x86_64 (@remi)
             php-common(x86-64) = 5.4.28-1.el6.remi
  Available: php-common-5.3.3-26.el6.x86_64 (base)
             php-common(x86-64) = 5.3.3-26.el6
  Available: php-common-5.3.3-27.el6_5.x86_64 (updates)
             php-common(x86-64) = 5.3.3-27.el6_5
  You could try using --skip-broken to work round the problem
  You could try running: rpm -Va --nofiles --nodigest

How could I install it on php 5.4?

1

You originally installed PHP from the remi repository, but you forgot to enable the repository when adding this package.

To fix the problem, re-enable the repository, either temporarily: yum --enablerepo=remi install php-xml or permanently by editing /etc/yum.repos.d/remi.repo.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.