4

I have a working IIS 8.0 server (on Windows Server 2012) that has a working SSL installation. The certificate is due to expire in a few days, so I am trying to renew it.

When I try to create a renewal request in the IIS Manager, it fails when clicking Finish with the following:

---------------------------
Renew an Existing Certificate
---------------------------
There was an error while performing this operation.



Details: 

Object reference not set to an instance of an object.
---------------------------
OK   
---------------------------

When I try to do it through the Certificates snap-in in MMC, I find I don't have the option to renew in the context menu. I believe both of these issues are due to the certificate being located in the WebHosting (Web Hosting) certificate store.

How do I create a renewal request in this circumstance?

Thanks!

  • This error is not fixed (or the exception not handled) in the IIS8 either (under the latest service pack etc). If it is not supported they shouldn't even list this option. Or at least a more meaningful error displayed. Creating a new request seems to be the only option currently – Alex Apr 16 '15 at 4:45
1

OK, well, it turns out, "renewing" was not what I wanted, although you would think it was. Looking at https://www.geocerts.com/csr/iis_renew_7 told me that I just wanted to issue a new request, not do a renewal.

I tried moving the cert to Personal, which let me issue a renewal request, but the CA (Network Solutions in this case) didn't like that request. They were fine with the new request though. So it all worked out from that in the end.

1

I came across the same problem, and ended up creating a new request instead of "renewing." Apparently there is a way to fix the Renew functionality though - see https://blogs.msdn.microsoft.com/sroun/2014/07/25/fixing-object-reference-not-set-to-an-instance-of-an-object-when-using-shared-configuration-in-iis8-x/

  • sorry - I tried to do what's described in that MSDN blog - did not fix it for me. – vlad seder Mar 29 '16 at 11:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.