4

How do I use StandAlone on WDS without a Domain?

The Client asks for a Domain Login when I boot to PXE. My server is running in StandAlone mode which I though would bypass this requirement.

I've read tutorials, but they require a lot of wim editing, registry settings, and don't apply to Windows Server 2012 r2. Most are three plus years old.

I'm avoiding a Domain since this is a home setup and every person has their own machine. They don't want the scenario of the AD DC going down and being stuck without a computer. These are personal computers. We run a PXE server to avoid looking for DVD's and risking a bad disc. Plus it gives the file server other helpful uses.

-- Origin Problem --

Right now I'm using pxelinux though a third party tFTP server with PXE support. I have a WinPE DVD Image loading via memdisk which has the command to smb to a folder on the server and execute a bat file that is a menu for the various Windows Installs we use. In short, it's a dirty solution.

I want to use WDS so that I can drop a ton of files and clean up the system. I like the idea of using WIM files, but linuxpxe doesn't like them and I haven't figured out how. I'd also like to drop third party tftp software.

3

Have you tried using the Microsoft-Windows-Setup\WindowsDeploymentServices\Login settings in your Client unattend file? This will allow the system to log in automatically. In the domain field, you would use the server name (Freya).

The article Windows Deployment Services Getting Started Guide for Windows Server 2012 has instructions for both domain and non-domain WDS setups, and the Unattended Windows Setup Reference has all of the components and settings available, however I would recommend using WSIM to build your unattend files.

As Mbond65 mentioned, the Microsoft Deployment Toolkit (MDT) is a great tool for deployments and can allow you to keep fewer images with MDT adding customization during the deployment, including contacting your WSUS or Windows Update to allow a fully updated system when the deployment is finished. Here are a few links that may help you with your deployments:

Deployment Day Session 3: Deployment using WDS

Windows 8.1 Deployment Jumpstart

Deployment Day Session 1: Introduction to MDT 2012

Deployment Day Session 2: MDT 2012 Advanced

Hope this helps,

3
  • The problem is "At the Connect to Your WDS Server authentication dialog, enter your local user account and password. Click OK." which I can't make an answer file for. Its the Boot image, not the install image. This boot image loads the windows setup pre-wim. I select the OS I want to install after this login request. – Kayot May 26 '14 at 2:15
  • 1
    Yes, the client unattend file runs during the WinPE boot. This is where you put your WDS credentials and format the drive. Please see Sample Unattend Files and Automating Setup for more explanation on client and image unattend files with WDS. – dwolters May 27 '14 at 16:03
  • I finally understand what you meant. Recently I deployed a WDS server at work and I started using the ADK. This with SysPrep has saved me. – Kayot Jul 18 '16 at 22:10
0

Presumably you're prompted for a username and password when you try to install am image rather than booting from pxe? When you boot from PXE, the client obtains a DHCP address from either your WDS server if it's running DHCP or another DHCP server on your network.

The client then obtains binary files for WinPE via TFTP.

Once done you will be prompted for a choice of install images.

Note that when you install an image, the client will be installing the image using the protocol SMB.

Also, you alot of people use MDT and restrict NTFS and share permissions on their deployment share to stop clients on the network re-imaging their machines or bringing in their laptops and imaging them using a corporate image. This means that when you boot the MDT image from WDS, the image will contact the Deployment share on the network and try to authenticate, prompting you for credentials.

If you are using just WDS , I would check the share and NTFS permissions of a folder called "RemoteInstall".

The remote install folder can be accessed by navigatingto \WDSServername.

The shared name of the folder is "REMINST".

For this folder, I would check that "Everyone" has read share permissions and read NTFS permissions.

I would also take a picture of the authentication prompt you are receiving and post it to on this question.

4
  • I added "Everyone" to the security and share group lists. It still prompted a login. I went ahead and made a user named PXE with the password PXE and I was able to login. I haven't attempted to install an image as of yet. I'm trying to figure out the unattend.xml to auto login. Though I'd prefer to bypass it all together. – Kayot May 21 '14 at 1:28
  • i58.tinypic.com/332tfv9.jpg - Here's what it looks like, I hope I'm posting this right. – Kayot May 21 '14 at 20:18
  • Thanks Kayot, that helps alot. As I say, after the intial transfer via TFTP , WDS installs the image using the SMB protocol and will require authentication to the remote install share on your WDS server, looks like your WDS server is called "Freya". Can I ask whether when you set the NTFS permissions to everyone on the Remote Install share that you also configured the Share permissions aswell. Remember that in a Windows environment, between share and NTFS security permissions, the most restrictive applies. Ensure that both Share and NTFS permissions are set to "Everyone". – Mbond65 May 21 '14 at 20:37
  • Here are my settings. i57.tinypic.com/35d6o0x.gif I went ahead and migrated my file server to 2012r2. Freya was my laptop. – Kayot May 26 '14 at 2:17
0

I was having the same issue. Use the computer name of your server + \ + Administrator with your Administrator's password. For example, your user might look something like this: WIN-BT3E8B00D4T\Administrator.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.