HP Proliant Microserver Gen8; Server 2012 R2; Three 1TB SATA Harddrives, two arrays: 1 Raid 0 OS drive, 2 Raid 1 Data drives

"The drive where Windows is installed is locked. Unlock the drive and try again."

I came into the office on a Monday morning to that message.

This Screen (from Ideaz): From Ideaz

Command takes me to X: drive, and cannot access C:

Also, from command line - Diskpart list vol, disk, part all reported no drives, volumes or partitions.

HP ACU (Array Configuration Utility) reported 100% disk space used on both arrays. Raid Controller Log showed no HD errors or controller errors or cache errors, etc. Clean log.

I was afraid we had lost everything. After 2.5 hours on my own, and 2.5 hours with HP tech support, we found the answer.


We tried lots of different things, from reseating all the HD, to making sure all connections were solid on the board, to power cycling, to configuration changes, etc....

As the last option, we pulled the two data drives and booted just with the OS drive. I allowed the RAID controller to think the two data drives had failed. The server booted up and applied Windows updates. I logged in/shut-down and reinserted the two data drives. Booted up no problem. Everything is now working fine.

So, maybe its a configuration problem on my end with the SATA HD. Maybe it was a Windows Update issue. Whatever it is, I'm posting what worked for my situation.

Maybe someone will edit this post for better readability.

  • Thanks for sharing, hopefully it will come in handy for someone else, however it doesn't exactly answer why; it just shows what you did for a workaround. I would want to know the root cause and if there was the potential for this to happen again. I'd first start by checking your RAID controller and see if it shows any errors. A lot of RAID (hardware) controllers will show you disks that are in what we call a predicted failure state meaning that there are elements detected on the actual physical drives that will lead them to eventually fail, and although they haven't failed yet it's a good idea – Brad Bouchard May 20 '14 at 17:16

Not the answer you're looking for? Browse other questions tagged or ask your own question.