4

So, i'm getting an error because my .sock file is not being created by uwsgi. I'm also running a VB with vagrant.

my uwsgi.ini

[uwsgi]
master = true
pidfile = /tmp/uwsgi-%n.pid
workers = 12

enable-threads = true

uid = www-data
gid = www-data
socket = /tmp/uwsgi-my-site.sock
chmod-socket = 777
virtualenv = /var/sites/%n/env
single-interpreter = true
chdir = /var/sites/%n
wsgi-file = app/main.py
logto = /vagrant/my-site/log/uwsgi.log
#stats = 127.0.0.1:1717

and my nginx.conf

server {
  listen       80;
  server_name  my-site.com;
  access_log   /var/sites/my-site/log/nginx_access.log;
  error_log    /var/sites/my-site/log/nginx_error.log;

  root /var/sites/my-site/app;

  location / {
    uwsgi_pass unix:///tmp/uwsgi-my-site.sock;
    include /etc/nginx/uwsgi_params;
  }

  location /static {
    alias /var/sites/my-site/app/static;
    expires 24h;
  }

  # Strip trailing slashes.
  rewrite ^/(.*)/$ /$1 permanent;
}

And my nginx error

2014/05/16 23:22:27 [crit] 3914#0: *1 connect() to unix:///tmp/uwsgi-foo.sock failed (2:        No such file or directory) while connecting to upstream, client: 10.0.2.2, server: foo.com, request: "GET / HTTP/1.1", upstream: "uwsgi://unix:///tmp/uwsgi-foo.sock:", host: "127.0.0.1:8080"

my uwsgi.log isnt even being written too.

  • old question, but did you find a solution to this? – tschale Nov 2 '17 at 12:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.