0

I have been trying to get swift CLI to work with Openstack on one of my machines and every time it returns the following error:

Authorization Failure. Authorization Failed: The resource could not be found. (HTTP 404)

A curl call to the identity server (like the following) works just fine but I am not sure why the swift CLI doesn't work:

curl -d '{"auth":{"tenantName": "Test Tenant", "passwordCredentials": {"username": "username", "password": "(Usern&me"}}}' -H "Content-type: application/json" http://nova-ab.server.com:5000/v2.0/tokens

The credentials for the swift call are set as environment variables in the .bashrc file.

I am pretty new to openstack, so if any further information is required to identify the issue, I will be happy to provide it.

thanks!

  • The issue was that the certificate was not recognized. I added --insecure as an input option and things started working. – nemo May 20 '14 at 23:17
  • Please post this as an answer and mark the answer as "accepted" when the minimum accept delay has expired. This will prevent the question from showing up in searches for unanswered questions. – Andrew B May 21 '14 at 0:43
  • sure. At the moment I don't have enough reputation in this forum to be able to post an answer but will do so once that is resolved. – nemo May 21 '14 at 1:14
0

The auth url that the client expect is a bit different.

instead of http://nova-ab.server.com:5000/v2.0/tokens use http://nova-ab.server.com:5000/v2.0/

It will work

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.