11

does someone faced error "The RPC server is unavailable" during connecting to Disk management MMC console to Hyper-V Server R2? Servers are in the same AD domain and MMC console is enabled on Hyper-V.

Thanks

  • Both source and destination are 2008 R2? – Kara Marfia Aug 28 '09 at 14:28
  • Yes. Both R2. I can access firewall settings, server management snapin but Disk Management returns mentioned error. – GrZeCh Aug 28 '09 at 18:49
21

You need to change the Firewall rules on both machines (NOT only the Hyper-V Server)

Run this command on both machines:

netsh advfirewall firewall set rule group="Remote Volume Management" new enable=yes

|improve this answer|||||
  • 2
    GREAT. Updating firewall on both sides was the case. Thank you – GrZeCh Aug 29 '09 at 11:35
  • I'm still getting this. It was succesfull on my physical machine, but when I executed this command on my Virtual Client, it said: "No rules matched the given criteria". That's translated, since the machine runs Dutch language. – KdgDev Oct 1 '10 at 10:14
  • @KdgDev you will need to find the Dutch version of that text "Remote Volume Management" – user230910 May 31 '17 at 14:29
1

For errors "RPC Server is unavailable" when trying to use Disk Management MMC or Server Manager MMC or Computer Management MMC to connect to a Windows Hyper-V (Hyper V) Core Server, please note the following: 1. Enabling "Remote Volume Management" needs to be done on both machines... the Core Hyper V Server and the client machine: On the client machine (Windows 7 and Windows 8 ... XP is no longer supported... lol ;), "netsh advfirewall firewall set rule group="Remote Volume Management" new enable=yes" will run smoothly.

On the Windows Hyper-V (hyper V) Core Server (in my case I am on Server 2012 R2), I was not eble to run the netsh command. I was able to enable "Remote Volume Management" by using the GUI tool "Corefig for Windows Server 2012 Core and Hyper-V Server 2012"... *downloadable from http://corefig.codeplex.com/releases. Version 1.1.1 was stable enough. Good luck!

|improve this answer|||||
  • This fixed my problem. Even though the firewall rule on the server was enabled, I needed to enable it on the computer where the management console was running also. – Sebazzz Mar 9 '18 at 11:13
0

Be aware that Windows is using dynamic port allocation for some services e.g. Disk management. https://support.microsoft.com/en-us/kb/929851?wa=wsignin1.0 Meaning Microsoft finally uses one of these ports 49152 - 65535.

|improve this answer|||||
0

You need to change the Firewall rules on both machines (NOT only the Hyper-V Server)

Run this command on both machines:

netsh advfirewall firewall set rule group="Remote Volume Management" new enable=yes

In Brazilian Portuguese, the group name is "Gerenciamento de Volumes Remoto".

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.