2

Long time ago I set up an environment where my Linux machine (LM) was a synergy server and my Windows machine (WM) the synergy client as described here.

Since our admin put in a Linux jump server (JS) I'm not able to tunnel between both machine.

Here some question: On the windows machine I configure Putty in that way:
Session -> HostName: jumpserver Port: 22.
Connection -> SSH -> Tunnels L24800 LM:24800.

My understanding is that a connection to the jump server will be set up and the a ssh hopping starts to the Linux machine. Even if I have a logging on the jump server I can not confirm that the tunnel is set up. Even I miss the part where I'm telling the JS to forward all requests to the LM and vice versa.

If I used with Putty Connection -> SSH Remote command and putted ssh LM the first time I recognized that I was able to set up a connection to the JS and then to the LM. But synergy did not accept that way.

How can I set up a tunnel from a Windows machine with Putty over a Linux jump server to a Linux machine? How must I configure synergy?

Thanks in advance.

2

You need two port forwarding, the first from JS to LM and the second from WM to the previously created on JS. Add to your Putty configuration the following line in the SSH menu under remote command:

ssh -L 24800:localhost:24800 LM

Under Tunnels configure the port forwarding like you are connecting directly to the LM

L24800 localhost:24800

Once you connect with Putty from the client machine WM to the jump server JS, you can check the Event Log to see if the tunnel is up. Just click with the right button on the bar at the top of the Putty window anche select Event Log in the menu. You should see something like this:

2014-05-21 18:14:16 Local port 24800 forwarding to localhost:24800

Your client should be configured to connect to localhost:24800.

  • Thanks, in the event log I saw an error message: 'forwarded connection refused by server administratively prohibited open failed' I changed the port 24800 to 22. The tunnel is set up now. – Clueless May 22 '14 at 6:55
  • Have you solved your issue? If so, please mark the answer as correct – Guido Vaccarella May 22 '14 at 13:04
  • No. I recognized that you mean the linux/jump server and not the linux machine as final destination. So far as I understand I build up a connection to the linux server and on the server a port forwarding to the linux machine. The entry is '2014-05-21 18:14:16 Local port 24800 forwarding to linux machine:24800'. If I then try from the Windows machine a port forwarding for Synergy with L24800 localhost:24800 I get "Forwarded connection closed by server". I don't understand the localhost entry. – Clueless May 23 '14 at 9:10
  • Sorry, I've totally missed your link with your previous configuration. I have updated my answer. – Guido Vaccarella May 23 '14 at 11:00
0

Finally I got it to work. Here the final settings in our environment.

In the first session of putty I added:
Session -> HostName: jumpserver Port: 22.
Connection -> SSH -> Tunnels L24800 LM:22

Then I must set up second putty session as partially described by Guido:
Session -> HostName: localhost Port: 24800.
Connection -> SSH -> Tunnels L24800 localhost:24800

After running both session synergy works without changing any previous settings.

  • You can do it with just a Putty session, look at my answer! – Guido Vaccarella May 23 '14 at 11:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.