0

I'm having trouble with permissions on a samba shared folder on ubuntu server 14.04. This is the www one. But actually, it's in /home/administrateur.

As I want to preserve my www folder whatever happens, I put it in my /home/administrateur folder. For the permissions via chmod, I have 644 on files and 755 on folders. The owner is administrateur:administrateur. I activated userdir mod in order to permit apache to load any site which is in /home/administrateur/www. And it works. Now, I need this folder to be accessible from my windows network. So I added Samba. I set it up like this :

[www]
    comment = Accès R/W/X pour tous
    path = /home/administrateur/www
    guest ok = Yes
    read only = No
    create mask = 644
    directory mask = 755

It shows in my network as expected, but when I try editing anything in it from my win 7, it says that I need to have an authorization from my ubuntu-server\ administrator to modify is.

I dont want to give individual permissions, I want any machine in my network to be able to r/w/x what is shared by the ubuntu server.

What am I missing ?

0

If you try editing the files on ubuntu-server\ from a windows machine without using samba-credentials then you do this as guest. The guest-account itself has no permission to edit these files.

The persmissions should be 777 on files if you want r/w/x these files without using samba-credentials of the ubuntu-server.

For security reasons you should always use the samba-credentials with r/w/x permission on the share. Setting files to 777 should only be done for test purposes.

  • Thanks for answering, but the 777 return the same issue. I'm really stuck. – Neovea May 22 '14 at 15:40
  • Could you please post the output of ls -l home/administrator/? – bitskull May 23 '14 at 5:45
  • drwxrwsrwx 10 administrateur users 4,0K mai 23 09:30 www – Neovea May 23 '14 at 7:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.