28

====================================================================

UPDATE: It turned out the configuration of sshd on host2 wont allow password login. Thanks to people answered this.

====================================================================

Scenario: Working with a company for my college project. I need to use PuTTy to SSH into host1 first, and from there SSH into host2 (see below). I was given a username and password on host2.

I do not have access of host2 at all, so I have no knowledge of its sshd_config.

This is what happened when I was trying to SSH into host2 from host1 :

ff@host1:~$ ssh -v host2
OpenSSH_5.1p1 Debian-5, OpenSSL 0.9.8g 19 Oct 2007
debug1: Reading configuration data /home/ff/.ssh/config
debug1: Applying options for *
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Connecting to host2 [192.*.*.*] port 22.
debug1: Connection established.
debug1: identity file /home/ff/.ssh/identity type -1
debug1: identity file /home/ff/.ssh/id_rsa type -1
debug1: identity file /home/ff/.ssh/id_dsa type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_4.3
debug1: match: OpenSSH_4.3 pat OpenSSH_4*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_5.1p1 Debian-5
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-cbc hmac-md5 none
debug1: kex: client->server aes128-cbc hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host 'sd01' is known and matches the RSA host key.
debug1: Found key in /home/ff/.ssh/known_hosts:1
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,gssapi-with-mic,password
debug1: Next authentication method: gssapi-with-mic
debug1: Unspecified GSS failure.  Minor code may provide more information
No credentials cache found

debug1: Unspecified GSS failure.  Minor code may provide more information
No credentials cache found

debug1: Unspecified GSS failure.  Minor code may provide more information


debug1: Next authentication method: publickey
debug1: Trying private key: /home/ff/.ssh/identity
debug1: Trying private key: /home/ff/.ssh/id_rsa
debug1: Trying private key: /home/ff/.ssh/id_dsa
debug1: Next authentication method: password
ff@sd01's password:
debug1: Authentications that can continue: publickey,gssapi-with-mic,password
Permission denied, please try again.
ff@sd01's password:
debug1: Authentications that can continue: publickey,gssapi-with-mic,password
Permission denied, please try again.
ff@sd01's password:
debug1: Authentications that can continue: publickey,gssapi-with-mic,password
debug1: No more authentication methods to try.
Permission denied (publickey,gssapi-with-mic,password).

and my /home/ff/.ssh/config :

Host *
#   ForwardAgent no
#   ForwardX11 no
#   ForwardX11Trusted yes
#   RhostsRSAAuthentication no
#   RSAAuthentication yes
#   HostbasedAuthentication no
    BatchMode no
#   CheckHostIP yes
#   AddressFamily any
#   ConnectTimeout 0
#   StrictHostKeyChecking ask
#   IdentityFile ~/.ssh/identity
#   IdentityFile ~/.ssh/id_rsa
#   IdentityFile ~/.ssh/id_dsa
#   Port 22
#   Protocol 2,1
#   AuthorizedKeysFile .ssh/authorized_keys
#   Cipher 3des
#   Ciphers aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour,aes192-cbc,aes256-cbc
#   EscapeChar ~
#   Tunnel no
#   TunnelDevice any:any
#   PermitLocalCommand no
    SendEnv LANG LC_*
    HashKnownHosts yes
    GSSAPIAuthentication yes
    GSSAPIDelegateCredentials no

I wonder is there anything I can do before go to the company.

5
  • is the username "ff" on host 2 correct?
    – etagenklo
    May 23, 2014 at 11:52
  • @etagenklo yeah that's what I was given.
    – gherkin
    May 23, 2014 at 12:21
  • You should ask the administrator of host2.
    – jornane
    May 23, 2014 at 16:25
  • I had the same issue. I think the cause is that I had something set up wrong in the user's $HOME/.ssh folder. After mv $HOME/.ssh $HOME/.ssh.hide I could log in using ssh password May 27, 2015 at 20:51
  • I'm not allowed to answer this post. But I've succeeded to SSH into remote machine in this way: medium.com/@farhan.tanvir.utshaw/…
    – Utshaw
    Jun 5, 2020 at 4:47

9 Answers 9

16

The username and password you are trying are not accepted by the host. That means either you are connecting to the wrong server, or the username or password is incorrect. You should ask the administrator to check the logs on host2, that should tell you which of the three is the case.

2
  • 2
    It's like could you be any more stupid, ofc I have the right passwords. And then you remember different keyboard layouts. Thanks for making me revisit :)
    – skyw00lker
    Oct 28, 2016 at 14:55
  • @skyw00lker That's the reason I personally use alphanumeric passwords.
    – kasperd
    Oct 28, 2016 at 20:17
12

First

 chmod 700 .ssh

and then :

 chmod 600 .ssh/authorized_keys

and test this :

restorecon -r -vv .ssh/authorized_keys
3
  • 3
    This works. Thank you! Nov 4, 2019 at 14:14
  • 1
    Its worked Thanks you Mar 2, 2020 at 5:59
  • 1
    All the permissions were correct. restorecon did it for me. Thank you!
    – h q
    Apr 12, 2021 at 9:42
2

I had the same problem, but the issue for me was that the default configuration of the operating system (CentOS 7) was to encrypt the user directory, so that the authorized_keys file placed in ~/.ssh/ would not work. The solution came from here but basically:

  1. in /etc/ssh/sshd_config set the AuthorizedKeysFile property to something outside of the user's directory (/etc/ssh/authorized_keys)
  2. restart the sshd service
2

In my case, It was caused by encryption of the home directory. I have changed the location of the ssh keys and it resolved the issue : (Web Archive copy) http://tweaktheserver.com/ssh-cant-connect-authentications-that-can-continue-publickeygssapi-keyexgssapi-with-micpassword/

5
  • 2
    Please add the essence of the solution into your answer. Link-only answers are susceptible to link rot. Apr 20, 2015 at 6:11
  • Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. Apr 20, 2015 at 6:26
  • thanks for your suggestions. I understand that a working link can be a '404 error' in future and it is important to mention the points in the answer itself. I have edited my answer as well.
    – user173141
    Apr 26, 2015 at 5:45
  • @DeerHunter was prophetic: link rotted
    – Riet
    Feb 5, 2016 at 23:34
  • @Riet - edit suggested. All is not lost. Meanwhile you can visit the captured copy of the page. Feb 5, 2016 at 23:42
1

GSSAPI authentication seems to be enabled in the client, yet it fails and falls back to password authentication. If you cannot login with supplied login and password, then the only sensible thing to do is to contact someone responsible for managing the server (the "company").

-1

Let me add that you should ensure that the key belongs to your user.

Type ls -la to see which user your key belongs to.

You can change the ownership:

sudo chown ubuntu:root myKey  //If you are using ubuntu.

Also ensure:

  • You are using the correct .pem key if using linux (putty is different)
  • You have set the correct key permissions: sudo chmod 400 mykey.pem
  • You are using the correct username: ssh -i mykey user@instanceip
-1

try:

ssh server -p port -o PreferredAuthentications=publickey
1
  • please be a little more verbose about why the OP should use your command and what it does. also using code styling for commands is deemed good style: `` May 1, 2019 at 19:26
-2

You can try

ssh server -l user -o "PubkeyAuthentication=no"

OR in /etc/ssh/sshd_config, add/modify the property

PermitRootLogin yes
1
  • ssh server -l user -o "PubkeyAuthentication=no" equal ssh user@server -o "PubkeyAuthentication=no"
    – Adriano
    Apr 11, 2017 at 12:03
-2

$ ssh [email protected] -i .vagrant/machines/default/virtualbox/private_key

This worked for me

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .