23

We need to disallow the domain Administrator account to access a server directly via RDP. Our policy is to log on as regular user and then use Run As Admin functionallity. How can we set this up?

The server in question is running Windows Server 2012 R2 with Remote Desktop Session Host and Session Based RD Collection. Allowed User groups do not contain the domain Administrator user but somehow he is still able to log on.

Thank you.

migrated from superuser.com May 24 '14 at 9:09

This question came from our site for computer enthusiasts and power users.

  • You don’t. (filler) – kinokijuf Mar 26 '14 at 10:05
  • 1
    I have never heard of someone settings permissions for the Domain Admin... haha – pulsarjune Mar 26 '14 at 10:06
  • Which policies exactly did you modify, list them, in your question. – Ramhound Mar 26 '14 at 11:20
  • @Ramhound I didn't think of using GPO, I thought this was only matter of setting up the Remote Desktop Services tab somehow. – r0b0 Mar 26 '14 at 12:14
  • 1
    @pulsarjune I come from unix background where it is quite common to disable root login via ssh and only use su/sudo. This is not tha case in Windows I suppose? – r0b0 Mar 26 '14 at 12:16
29

This seems to be what you are looking for: http://support.microsoft.com/kb/2258492

To deny a user or a group logon via RDP, explicitly set the "Deny logon through Remote Desktop Services" privilege. To do this access a group policy editor (either local to the server or from a OU) and set this privilege:

  1. Start | Run | Gpedit.msc if editing the local policy or chose the appropriate policy and edit it.

  2. Computer Configuration | Windows Settings | Security Settings | Local Policies | User Rights Assignment.

  3. Find and double click "Deny logon through Remote Desktop Services"

  4. Add the user and / or the group that you would like to dny access.

  5. Click ok.

  6. Either run gpupdate /force /target:computer or wait for the next policy refresh for this setting to take effect.

  • Anyone tested this to be working? – Pacerier Mar 13 '15 at 17:34
  • 2
    I think it's better to remove Administrators from "Allow logon" and add individual admins to "Remote desktop users" group – basin Jul 26 '16 at 12:16
  • @Pacerier I've tested this in 2012R2 and it works. My next attempt to RDP in told me I needed the right to sign in through Remote Desktop Services. I was still able to RDP in as another user though, and was able to connect to Administrator's existing desktop session through Task Manager. – mwfearnley Feb 9 '17 at 11:14
  • Thank you! I was actually searching a way to prevent a username to log in locally (making an RDP-only user), and I found it just next to this one. Neat. – Evengard Apr 3 '18 at 23:35
-3

I created a simple tool that does this and couple other features, you can find explanation here: https://www.linkedin.com/pulse/combating-ransomware-wannacry-more-home-user-edition-djenane

but essentially you can do it through command line:

Reg add “HKEY_LOCAL_MACHINE\SYSTEM\CurentControlSet\Control\Terminal Server”  /v fDenyTSConnections /t REG_DWORD /d 0 /f
  • 2
    This command disables Remote Desktop connections for all users, not only the Domain Administrator account as requested by the OP. – Twisty Impersonator May 19 '17 at 21:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.