8

I suddenly get the error 550: Permission Denied in Filezilla when I try to create a new directory.

A few days ago I changed some settings on the server regarding ssl and imap settings, but I don't think this has affected the FTP settings ...

Anyhow, after long googling nothing seems to work. The main idea could be that the user hasn't got permissions, but the interesting thing is that I can:

  • create files
  • delete files
  • delete directories

But not creating directories. I get the error "550 Permission denied" in the main directory and "550 access_log: No such file or directory" in the subdirectory.

Anyone knows where the error could be? Thanks

  • maybe sometimes there is a file name restriction and the file name didn't meet the requirement – user238836 Aug 22 '14 at 5:37
2

I got a 550 using FTP with Filezilla because regular FTP didn't have high enough permissions on my server.

I switched to an SSH/SFTP connection and that fixed it.

1

Assuming you are on Linux, Go up one directory, and see if the user has permissions there. For example:

Try setting the permissions on the directory to 777. If it works you know you have a problem with the permissions. DO NOT leave the directory at 777, it is not secure, just for quick testing. 755 is usually appropriate if you have everything set up correctly. You can also try adding the user to the group that owns the directory (you can do this through ls -l). This will tell you what user owns that.

  • 1
    For a directory 644 would be a bad mode, since it lacks x and the directory cannot be entered! – Janne Pikkarainen Aug 22 '14 at 5:45
  • You are absolutely right, I was getting my file and folder settings confused. – David Eisen Aug 22 '14 at 11:54
1

Filezilla project has a good piece on Securing your Windows Service installation. In essence:

Create User

  1. Close the Filezilla interface (if open)
  2. Stop the Filezilla service
  3. Create a User level (not Administrator level) Windows account for FileZilla service to run under, with "password never changes"
  4. In Services, open Filezilla properties, Log On tab and change to run with the new account

Folder Permissions

  1. Give Write permissions to the new user on C:\Program Files (x86)\FileZilla Server\FileZilla Server.xml
  2. If you use logging, set "Write" access to C:\Windows\Logs
  3. On target FTP upload folders set "Full Control" to each topmost writable folder you want to use

Restart Service

0

Use below parameter in vsftpd.conf to give permission to anonymous user or script in linux machine.

  • write_enable=YES
  • anon_mkdir_write_enable=YES

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.