4

I'm using Xenserver 6.2 and configured ssmtp.conf an mail_alert.conf in order to receive alerts through email. I followed the instructions on http://support.citrix.com/servlet/KbServlet/download/34969-102-706058/reference.pdf document. I'm using gmail smtp to send the emails. When i try:

[root@xen /]# ssmtp emailaddress@domain.com

from the command line and try to send the email, no problem. It is right on the way. But when i set some VM to generate alerts, alerts are generated. I see in XenCenter but emailing is not working. I see this in /var/log/maillog file:

May 27 16:17:09 xen sSMTP[30880]: Server didn't like our AUTH LOGIN (530 5.7.0 Must issue a STARTTLS command first. 18sm34990758wju.15 - gsmtp)

From command line every thing works fine. This is the log record for the above command line operation:

May 27 15:55:58 xen sSMTP[27763]: Creating SSL connection to host
May 27 15:56:01 xen sSMTP[27763]: SSL connection using RC4-SHA
May 27 15:56:04 xen sSMTP[27763]: Sent mail for emailaddress@gmail.com (221 2.0.0 closing connection ln3sm34863740wjc.8 - gsmtp) uid=0 username=root outbytes=495

Any ideas?

1 Answer 1

1

It would be useful that you post the contents of your /etc/ssmtp/ssmtp.conf and /etc/mail_alert.conf files.

Anyway, have you tried to include UseTLS=YES in /etc/mail_alert.conf?

2
  • Unfortunately that system is gone now. So i cannot post these files. And for UseTLS=YES option : yes i tried. (As i remember). Now i use 6.5. As soon as possible i will try that on that system. Thanks. May 28, 2016 at 11:01
  • Sorry. I didn't notice that the question was quite old before answering.
    – rpet
    May 30, 2016 at 8:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.