1

I have this one server that just doesn't want to be on the internet

It's a new server, a twinblade, the other twin works, but not this one.

It can connect fine to everythign else in the LAN, but cannot go out on the net

It can be reached by ICMP requests over the net (the nagios server can probe it, but not ping it for instance), but not TCP

Everything seems fine both in firewall and machine, i get no issues.

Anyone care to help me out where i can start looking, i'm seriously confused.

edit: it can ping gateway and through the sonicwall site to site VPN, it\s also able to resolve DNS. the only thing it can`t do is reach anything outside of LAN/VPN

2
  • Can it ping its gateway? Can it ping websites by IP but not name, or neither? As a test, if you turn off Windows Firewall, does it then resolve the issue? I need a little more info, then I can help. – Brad Bouchard May 27 '14 at 22:43
  • Try some traceroutes to known IPS outside your net. Sounds like a gateway problem. I assume it has a static public ip assigned? Netmask set accordingly? – Ryan Griggs May 28 '14 at 1:52
0

Depending on how far back you need to step in order to confirm what's working and what's not, here are some troubleshooting techniques I use:

  • check that the network card is showing up fine in Device Manager and make sure you're using the correct drivers
  • with knowledge about your network set a fixed ip address for the adapter. Make sure the ip address for the gateway and a dns server are set up (the dns ip doesn't have to be on your network).
  • if you have more than one ethernet card in the machine, disable other cards so you can isolate the issue better.

Then run some tests:

  • do a ping to a known host ip address on your network

  • If that works, try to ping an internet address (e.g. ping a host like www.serverfault.com and use the reply ip addresses to ping to, test this first on a machine that does connect to the internet so you know the machine you're pinging is actually replying back)

  • Try pinging a dns address (e.g. to www.serverfault.com)

If pinging works but TCP doesn't try to turn off the firewalls on both machines to make sure nothing is being blocked.

  • Try to use a third machine to confirm that the Nagios machine isn't the problem either.

It sounds like you may have made a typo in an ip address or netmask. Make sure you don't use the network's 'Network' and 'Broadcast' addresses (e.g. .0 and .255 when using a netmask with '0' at the end).

Unfortunately but often true for windows is to simply reboot the machine and try again.

Here is a site (not mine) that offers an online subnet calculator. http://www.subnet-calculator.com/ It may be overkill for what you're trying to do but sometimes it's just really helpful to see the scope of what is possible and what's not.

1
  • it can ping anything on LAN and VPN (site-to-site through gateway) but not anything outside. When i ping anythign outide, i get DNS resolved, but pinging an IP does not give any replies – Snowflow May 28 '14 at 7:57
0

There must have been something wrong with the DHCP lease or general error in the gateway.

I had tried refreshing the lease before etc, but what ended up fixing the problem was deleting the lease, releasing the IP, apply a new static IP and enabling the network again.

Absurd problem, but i should have tried this erlier

edit: i actually had a NAT rule that would translate my IP to another, so out it would work fine, but on resolve form the WAN area it would NAT it to a diff IP which wasnt in use...

Which explains the TCP connection timeouts i got earlier

TLDR: me monky

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.