1

I have two servers on VMWare. One is a standard install of Server 2008 r2 and the other is Server 2008 core.

Server 2008's IP is: 192.168.186.135 and computer name is: SERVER01. This is a domain controller and has DNS installed along with Active Directory. The domain is called: contoso.com

Server 2008 Core's IP is: 192.168.186.137 and computer name is: SERVER02

They can both ping each other, but when I try running the following:

netdom join SERVER02 /domain:contoso.com

Results:

The specified domain either does not exist or could not be contacted.

The command failed to complete successfully.

I'm thinking it might be a DNS issue? I'm new to servers and I am teaching myself. Any help would be appreciated.

Thanks in advance.

2

Your question needs a little more information:

I assume you have setup a domain called contoso.com and server01 is the domain controller ?

If you've followed any guide or similar, this should be the case, and you should also have setup server01 as a DNS server ?

If both of the above are complete, make sure server02 uses the IP-address of server01 as its only DNS server. You can run nslookup contoso.com on server02 and see if it can resolve the domain.

Edit: use netsh to set the ip/dns info on your NIC in server02 - first find which nics you have by running "netsh interface ipv4 show interfaces" - and then "netsh interface ipv4 add dnsserver name="1" address=192.168.186.135 index=1" - replace name="1" with what info you got from the first command.

See http://www.shariqsheikh.com/blog/index.php/200804/how-to-setup-ip-configuration-of-windows-server-2008-server-core/comment-page-1/ or generel google info for more information on this.

3
  • Added more info to my original question. You were right, my domain is called contoso.com and SERVER01 is the DC. SERVER01 has DNS installed. I tried using NSLOOKUP but it says: 'Unknown can't find contoso.com'. How would I use the IP of SERVER01 as the only DNS server on SEVER02 core? May 28 '14 at 9:00
  • I updated my reply with more info
    – Mwuanno
    May 28 '14 at 9:14
  • Excellent! This worked. Thanks so much. Basically, I ran the netsh command to show interfaces and my NIC (Local Area Connection) was showing as Index "21". So I used the following: netsh interface ipv4 add dnsserver name="21" address=192.168.186.135 index="1" and it worked May 28 '14 at 9:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.