3

Here is the scenario

I had a fully functioning SCCM 2012 site server with the DP, MP, SUP, Application catalog, etc. roles configured and working. There is only one server on this site. Everything was great but i was not happy with SUP, so i decided to create a separate WSUS server and configure Windows Updates through GPOs.

That setup worked great as well so i went ahead and removed the SUP role from SCCM and removed the WSUS feature from my SCCM server (they were configured on the same SCCM Server). I did not notice any problems right away.

A couple days later i noticed that the OSD deployments were giving errors, and after a couple hours of trying suggestions from Google, i was able to uninstall PXE and make a few changes and reinstall with WDS to get it working again. Again, thought everything was fine and continued on.

The last couple days i have noticed that any new machine deployed or installing the Client will show in the SCCM console as "No" Client. The client machines will show connected to a site but the software center shows "IT Organization" instead of our site like the previous clients.

The existing clients all seem to be functioning normally. they still receive application distributions and configuration baselines, etc.

Reinstalling, uninstalling and reinstalling, repairing does not fix the problems and this happens on all new clients. ClientLocation.log shows it connecting to the correct MP. Nothing odd in any of the logs except for the ClientMessaging.log which repeats continuously this line:

<![LOG[Raising event:

instance of CCM_CcmHttp_Status
{
    ClientID = "GUID:0450fde3-ab82-41bf-9c33-87a18113744b";
    DateTime = "20140528214824.993000+000";
    HostName = "SOUNDWAVE.domain.org";
    HRESULT = "0x00000000";
    ProcessID = 4092;
    StatusCode = 0;
    ThreadID = 3720;
};
]LOG]!><time="16:48:24.994+300" date="05-28-2014" component="CcmMessaging" context="" type="1" thread="3720" file="event.cpp:706">

thanks

1

Strangest fix i can think of... but i found this article and tried out one of the fixes and it seemed to fix the issue

http://social.technet.microsoft.com/Forums/systemcenter/en-US/ecd01dff-1f52-47fd-bc56-67e468fef7cb/sccm-client-issue-not-registering?forum=configmgrgeneral

I wound up copying the smsperf.dll file from the syswow64 directory into the system32 directory and the clients started working. Seems unlikely to me but its working now so i will leave it alone! :) Thanks

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.