1

I've actually looked up a number of solutions for this problem and none of them work. There's this Cisco ASA 5505 that I'd like to use, that outputs mildly garbled text with missing characters. I did some googling and found that the most likely problem is a bad baud rate, so I tried all the baud rates, 7N1, 8N2... basically every possibility minicom had. Then I figured (since I can type ok, just not read) that if I factory reset it that it would fix whatever is set wrong with the terminal. That didn't work either. This usb->db9 adapter and console cable work fine on the catalyst switch in our office. My serial settings are 9600 8N1 with no flow control. Anyone know how to fix this?

I have an example of the text on pastebin: http://pastebin.com/MAJF0mVU - it's just lots of "Dfaut cnfiuraionfil cotais 1enty." instead of "Default configuration blah blah"

2
  • Interestingly, it looks normal until it hits the "Launching Boot Loader" stage.
    – Davidw
    May 29 '14 at 2:55
  • Not that I don't want this answered, but I have an old Cisco 2650 at home that I know works that I think I'll bring in - all I want to do is static route voip over our DSL and everything else over the microwave internet... May 29 '14 at 3:05
2

can't post comments, pardon the intrusion.

you will most likely have to interrupt the bootloader (put it in ROMMON mode) and flash a new image.

it could be nvram corruption (actually, that would seem to indicate a problem in flash).

see: Cisco - Recover the Image on an ASA 5500 Series Security Appliance (PDF)

or it could just be some control message is being misinterpreted. have you tried a telnet/ssh client? but that kinda looks doubtful.

also, try different (lower) baud rates, could just be some settings on the unit, or erase nvram in rommon.

edit: --

well tbh, i've only dealt with asa devices on 2 occassions. so i just don't know enough about them to say.

i couldn't make any sense of that log file, but looking at it now. it is failing to load the image, at the very end: eadng romflah.. !. rypochcksm (nchnge): f290c46b337a 5f275f 184120

some checksum error

normal output is !!!!!!!!!!!... spam.

edit2 --

just some more info on erasing flash: erasing/formatting flash should check for/mark bad blocks. additionally, erase marks blocks as 0xFF and reinitializes the filesystem. some of this stuff i just learned today, so bear with me ;p

you can test the filesystem for bad blocks fsck -test flash. (these are bootloader commands) for a switch, the recovery looks something like format flash, flash_init, load_helper, copy image over, boot system flash:filename.

as per the following guide: Recovering Catalyst Fixed Configuration Switches from a Corrupted or Missing Image

bootloader cmd ref: Catalyst 2950 and 2955 Switch Boot Loader Commands

image/filesystem ref: Managing Software Images and Working with Configuration Files on Catalyst Switches

for asa 5500 series: ASA 8.x: Troubleshooting ASA Flash Errors

closest i could get for ASA. i always have issues finding detailed guides for them, so i tend to use the switch/router guides as additional info.

7
  • The image is what I suspect as well, given it seems to start after the boot loader stage.
    – Davidw
    May 29 '14 at 19:59
  • I tried getting some sort of ip management working, but it kept on erroring out on the interface name and I couldn't figure out what the actual error message said. I think I'll take your advice. I've tried all the baud rates (below 9600), and I'll try using cu or screen to connect instead of minicom before flashing the device. I seem to remember that cu is not shy about printing weird characters. May 29 '14 at 22:32
  • 2
    Thanks - I managed to get the flash upgraded, but it's still doing the same thing. While updating the device I discovered that its ethernet 0/0 wasn't working as well (which is why I hadn't been able to get telnet working in the first place), so I have a tcp connection to the device now. I think this device is just a bit broken, I was thinking that a faulty oscillator for the serial connection could possibly explain why it acts like the baud rate is a little off. Thanks for your help, I don't think I could have gotten it setup without the instructions. May 30 '14 at 22:59
  • 1
    @SomeLinuxNerd well, nvram/flash can go stale over time, and the data becomes corrupt. rewriting the data will fix the error in the file (ie: checksum), but it doesn't necessarily guarantee that the block isn't corrupt/faulty to begin with and may act up in the future. alternative is to replace the flash/eeprom. you can also boot from an image located on tftpd. as for the serial connection, it might be the cable. i've never had such an issue. i know 'prolific' adapters seem to work with most units. it may be some sort of clocking problem indeed.
    – porkchop
    May 31 '14 at 2:16
  • 1
    @SomeLinuxNerd added edit2 above, might help you diagnose the problem further, if it's related to flash.
    – porkchop
    May 31 '14 at 19:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.