1

DISCLAIMER: I am new to CentOS, so please forgive me if I overlooked something simple.

Here is my issue:

I recently just reformatted my server to CentOS 6.5 x64 and I have been having issues getting postfix to work.

I am following this guide: http://www.krizna.com/centos/setup-mail-server-in-centos-6/ to install postfix MTA.

I have followed all the steps but when I try to start the server (service postfix start) I get this error:

Starting postfix:[FAILED]

I have looked in my mail log and messages log and I see no errors regarding why it is not starting. Is there another log I should be looking in?

When I run the command

postconf -n

I get the following error:

postconf: error while loading shared libraries: libmysqlclient.so.16: cannot open shared object file: No such file or directory

I compiled the newest version of MySQL from source and it is working with apache, but I wasnt able to locate libmysqlclient.so.16, only libmysqlclient.so.18. Could it be that my version of MySQL is too new for the postfix version?

Postfix Version 2.6.6 (Installed with yum) MySQL Version 5.6.19 (Installed from source)

Whats even stranger is that I have another server running the same OS (Installed from the same disk) and postfix starts just fine. (Using the postfix that came with CentOS, nothing has been installed on my other server). Could this be an issue with how my OS was installed?

This problem is driving me crazy, any help would be much appreciated.

Note: All of this is as root, Naughty me! :-)

1

having that little experience with linux/Centos etc, you must use yum installer, compiling MySQL server and installing other packages with yum - never do this again. check what repositories you have already, at least i know that IUS and REMI have latest mysql packages and all dependencies. and run:
yum install mysql mysql-server

| improve this answer | |
  • I agree with your statement.What I tried to do caused more issues than just this. Although to go back to my original question, I fixed the issue by doing a symlink from libmysqlclient.so.18 to libmysqlclient.so.16. When I fixed the issue I got about 10 more so I ended up giving in and just doing everything via yum. Thanks for your reply! – Grant Martin May 31 '14 at 9:08
0

I solved this problem in by installing the mysql-community-libs-compat package. What you need to do is:

 yum provides "/usr/lib64/libmysqlclient.so.16"

and after you will need to run something like:

yum install mysql-community-libs-compat.x86_64

and now restart postfix

| improve this answer | |
0

The reason you had problems is because postfix (and several other packages) compile against the libmysqlclient.so.16 library. When you update to a newer version of MySQL, you still have to provide this library to satisfy the dependencies.

The IUS project has a package named mysqlclient16 that would solve this for you. Additionally, we have packages for MySQL 5.5, 5.6, and 5.7, ready to install (mysql55, mysql56u, and mysql57u, respectively). Compiling from source is not something most people have time for, especially when you consider the ongoing maintenance cost to keep the source install updated and secure.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.