1

I've removed the remote desktop host role from one of my Azue VM, so I can't RDP into it. I have tried to recreate the endpoints and even the VM with no luck. I can't either access remotely with Server Manager; getting this error: The client cannot connect to the destination specified in the request. Verify that the services on the destination is running"

I cannot connect remotely to the registry Make sure this computer is on the network, has remote administration enabled, and that both computers are running the remote registry service

PsPing tells me The remote computer refuses the network connection

Which workaround can I follow to solve this?

1

Your remote connectivity issue(s) aren't unprecedented, a TechNet Article advising resizing the VM from the managers console forces a refresh to default network settings.

http://social.msdn.microsoft.com/Forums/windowsazure/en-us/cb4a06b8-7aa3-45e4-aca8-0d3cbc69eb4b/unable-to-connect-to-azure-vm-using-rdp-connection?forum=WAVirtualMachinesforWindows

Remotely reinstalling RDP Server has various methods, you're already comfortable with those ?

  • Thanks for your answer, however I already tried resize and recreate the VM with no luck. – Jorge May 29 '14 at 10:59
1

So, at the end, as I needed some files from that VM, what I did is download the .vhd of that VM (it was in the Azure storage) and attach it as a new disk (thourg disk manager), so I was able to browse it.

After that, with the disk mounted, I could access the registry (regedit -> Load Hive) and enable back the RDP to the VM.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.