0

I had to restart my ColdFusion 9 server on CentOS because of a memory performance issue, but now the server won't restart again. When looking at cfserver.log I can see how there's "Permission denied" errors all along.

The ColdFusion application folder (/opt/coldfusion9/) is owned by nobody:root, as that fixed a similar problem that we had a few weeks ago. Also, the last time this CF server was running correctly, the JRE user that was being used was nobody.

Maybe CF is trying to restart using another user (presumably apache) and that creates permission issues? However, I'm not sure how to check this hypothesis.

Where's the config file that tells CF what JRE user to utilize? If I can change that, I could try to specify nobody there.

Any other ideas also welcome.

UPDATE:

The runtime user that Coldfusion will utilise is defined in /etc/init.d/coldfusion_9. I fixed the problem by being consistent with the users: I needed to revert the ownership of the folder /opt/coldfusion9/ back to apache:root, which matches the init file.

0

You can check the runtime user that Coldfusion is starting at by looking in the start up script:

/etc/init.d/coldfusion_9

The look for the for the following line:

RUNTIME_USER=""[user_will_be_here]""

5
  • That's useful, I've just checked that I have "nobody" as the RUNTIME_USER. However, after the last successful restart, CF's runtime user is set to "apache", contradicting what's in the init file. Is this setting being overwritten by something else? – Xevi Pujol May 30 '14 at 11:48
  • Not that I'm aware of. How did you restart CF? using /etc/init.d/coldfusion_9 restart – andrewdixon May 30 '14 at 12:15
  • No, using /opt/coldfusion9/bin/coldfusion restart – Xevi Pujol May 30 '14 at 12:50
  • That probably makes sense then. Check the "runtime_user" setting in that file. I would assume it is set differently to the one in the /etc/init.d/coldfusion_9 file, hence it starting with different users. When the system starts it will use the file in /etc/init.d/ however when you did it manually you used the file in the CF directory and if they are different then that is going to happen. – andrewdixon May 31 '14 at 9:29
  • The init file in /opt/coldfusion9/bin/ actually works off the main init file /etc/init.d/coldfusion_9. I just fixed the problem by being consistent with the user defined in the init and the user that owns the CF folder (as reflected in the question update) – Xevi Pujol Jun 4 '14 at 8:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.