0

I meet some problem when checking bundle dependency on

cd /var/www/openshift/broker 
bundle --local

This is the error message,

Bundler could not find compatible versions for gem "activesupport":
  In Gemfile:
    openshift-origin-controller (>= 0) ruby depends on
      activesupport (~> 3.2.8) ruby

    rails (>= 0) ruby depends on
      activesupport (4.0.0)

This is all my gem list

activesupport (4.0.0, 3.2.8, 3.1.0)
...
openshift-origin-admin-console (1.17.0.1)
openshift-origin-auth-mongo (1.15.1.1)
openshift-origin-auth-remote-user (1.17.1.1)
openshift-origin-common (1.18.0.2)
openshift-origin-controller (1.18.0.1)
openshift-origin-dns-avahi (1.10.2.2)
openshift-origin-dns-nsupdate (1.15.1.2)
openshift-origin-dns-route53 (1.10.2.2)
openshift-origin-msg-broker-mcollective (1.18.0.1)
...
rails (4.0.0)
rails-observers (0.1.2)
railties (4.0.0)
rake (10.0.4)

I'm working on fedora 20, I really dunno how to fix this, I'm not familiar enough with ruby, should I downgrade the rails version or else?

0

The unfortunate answer is that OpenShift Origin does not currently support Rails4, both the broker and the console need to be upgraded from Rails3 to Rails4 and it's unfortunately non-trivial. As a side effect, OpenShift Origin does not at this time support Fedora 20 and instead is sticking with RHEL/CentOS 6 and Fedora 19 for now.

However, there is currently work ongoing to get Software Collections included upstream in Fedora proper for Fedora 21 which will alleviate this issue in the future as we will instead package OpenShift Origin to leverage the SCL versions of packages we require. This will allow us to rely on a software stack (collection) that is loosely coupled with the operating system.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.