3

I have a website running v2.0 but I want the virtual directory running under it to use v4.0. I've already set the virtual directory as an application and gave it it's own application pool.

The server is running Windows Server 2003 SP2 (64-bit). However it has the Enable32BitAppOnWin64 flag enabled which means the ASP.NET tabs on the properties dialog of the websites/virtual directories are missing. .NET 4.0 is installed, aspnet_regiis -lv lists the 32-bit and 64-bit versions of .NET 2.0 and .NET 4.0 and the Web Server Extensions are enabled.

I can't disable the Enable32BitAppOnWin64 flag to get the ASP.NET tab back, so is there a way to do this from the command line without potentially breaking something?

I ran aspnet_regiis -lk to find the paths so I could try aspnet_regiis -sn, but it only returns one record

W3SVC/    2.0.50727.0

(There are 3 separate websites and a virtual directory running on the server though)

How can I change the framework version of the virtual directory without the ASP.NET tab?

  • Did you already try just changing the app pool that this new virtual directory is using to a different .net version? That is what I would do. – Brad Bouchard Jun 3 '14 at 19:44
  • @BradBouchard, how would you do that on Server 2003? In IIS7 I know it's simple, but I don't see that option anywhere in IIS6. – Brandon Jun 3 '14 at 19:47
  • Forgive me, I assumed IIS 7 before I read your question more closely. Is disabling 32bit an option? – Brad Bouchard Jun 3 '14 at 20:08
  • Forgive me again as I can see from your question that you say disabling 32bit isn't an option. But, do you mean you can't disable it permanently, temporarily, both, or simply that you don't know how? If you can disable it temporarily, I have a solution that would work, just let me know. – Brad Bouchard Jun 3 '14 at 20:24
  • @BradBouchard, It's not my server. I did think about disabling the option to get the tab back so I could switch the framework, and then re-enabling it, but I can't really do anything that might affect the other sites. Please feel free to post your solution as an answer though, it can't hurt to see what it is. – Brandon Jun 3 '14 at 20:40
2

To work around this problem, set the Enable32bitAppOnWin64 to False in IIS.

That is straight from Microsoft. Here is the Microsoft KB article referencing this limitation. They do however provide a link to this site detailing how to disable 32bit support.

My recommendation is to disable support for 32bit, create a new app pool just for this virtual directory that uses 4.0, re-enable 32bit support, restart IIS.

This MSDN blog claims that this is a "fix" for it, but I have not confirmed that with my lab setup.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.