0

My coworker and I are attempting to setup a two node "cluster" in which each node needs to access a file on the first node. To make this simple (it's a dev environment), he created a network share in which the entire X drive on the first machine is shared (Everyone > All Rights). So, ultimately, I can get to the file by accessing \\xxx.xxx.xxx.xxx\X\filename.txt.

What's interesting, though, is that, while I can access the first machine from itself by using the IP address, or localhost, I cannot access it by using the name I gave it (which I resolve using the hosts file on both machines). \\my.machine.name\X\filename.txt gives me a login dialog (which I can't login with using the local account OR a domain account). However, the other machine can use \\my.machine.name\X\filename.txt and it can access the share fine. It's very confusing, and I haven't been able to figure out what's causing it.

Both boxes are Windows 2012. The account I am using is a local account (on both machines - same account name). The IPs are static. Both machines are running inside VMWare's vCloud and are in the same vapp. Any insight or even a good way to debug this would be much appreciated.

  • Are you using lmhost or host file? Netbios names resolution use lmhost file. See support.microsoft.com/kb/105997/en – Jagj77 Jun 3 '14 at 18:45
  • I am not, but adding one does not change anything. I am still getting a "Enter Network Password" box. – JasCav Jun 3 '14 at 18:54
  • Are your servers in a domain? What are their host names? What is the domain name? – Daniel Jun 6 '14 at 17:27
  • @Daniel - No, they are not in a domain. It's a cloud on a corporate network where you pretty much have free reign to build and destroy boxes as needed. I think my ultimate solution may be to setup DNS on the servers so everything resolves nicely. I just don't understand why the machines can see each other, but not the Windows share... – JasCav Jun 6 '14 at 22:07
  • I reproduced your structure and it is working out of the box. You don't even need to change the hosts file as the servers resolve their hostnames via netbios. Installing a DNS server won't fix your problem. – Daniel Jun 7 '14 at 15:02
0

This problem occurs if you access the SMB share via an alias that is not the servers hostname or FQDN.

You can disable strict name checking in the registry. Browser to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters and create a DWORD with the name DisableStrictNameChecking and value 1.

http://technet.microsoft.com/de-de/library/ff660057%28v=ws.10%29.aspx

  • Thanks for the response, but this didn't work either (unless I completely missed something). – JasCav Jun 4 '14 at 16:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.