0

I need to listen events on port 3240 and I'm using node.js for that purpose. I need to execute my script with forever tool. I also need to run forever on server reboot.

When I run forever glh.js everything works: forever list says there is a running process.

But when I'm trying to run forever on server reboot I can't get it working.

I've created a file in /etc/init.d with the following content:

#!/bin/bash

/var/www/yan/data/gitlabhook/runglh.sh &>/var/www/yan/data/gitlabhook/runglh.log

When I reboot the server, the output log is the following (the same as when I run it manually via console):

info:    Forever processing file: glh.js

But in this case forever doesn't start a process. forever list outputs:

info:    No forever processes running
0

So at last I figured out that the script runs on reboot and is working, it is just not outputed by forever list. Seems to be a forever's bug.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.