0

I installed a php extension ioncube, and restart the httpd, then I got this error "httpd dead but subsys locked". I googled for the solution, and found out I need to comment out the line Zend_extension = /usr/lib64/php/modules/ZendGuardLoader.so in php.ini, Then I could start httpd with ioncube_loader enabled. But the problem is I need to keep ZendGuardLoader.so as well, since we have a php application that is using it.

How can I enable both ZendGuardLoader.so and ioncube_loader_lin_5.3.so at the same time without getting httpd dead but subsys locked error?

we are using centos 6.4, php 5.4

  • 1
    OK. I finally got it to work. I write solutions here, hope it will help other people. zend_extension=/path/to/ioncube_loader.5.3.so must be added right efter the line [php] in php.ini file, and infront of zend_extension=/path/to/ZendGuardLoader.so. that's it. – Zhenyu Jun 5 '14 at 18:33
  • Great , I did not know that ! – Alex H Jun 6 '14 at 7:12
0

You can actually have both enabled but you have to enable versions that are compatible with each other as each of them encrypt the content . It's an trial and error process unfortunately as far as I know .

  • can you explain a little more about the right versions? i'm using ionloader 5.3 and ZendGuardloader 5.3, which gives me the error subsys locked. which versions do you suggest me to use? thanks. – Zhenyu Jun 5 '14 at 18:16
0

One problem here is that the user had Zend and ionCube Loader components for PHP 5.3 yet they were using PHP 5.4, though they later claim they had it working with the 5.3 Loaders meaning that they had PHP 5.3 and not PHP 5.4. Also seems that a Chinese site serverquestions.com leaches items from here now (http://serversquestions.com/sq/questions/view/166433)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.