Here is the result of df on my target computer ~# df -h Filesystem Size Used Avail Use% Mounted on /dev/mapper/vgsys-lvroot 11G 5.4G 5.0G 52% / udev 24G 4.0K 24G 1% /dev tmpfs 4.0G 256K 4.0G 1% /tmp tmpfs 4.8G 6.1M 4.7G 1% /run none 5.0M 0 5.0M 0% /run/lock none 24G 0 24G 0% /run/shm /dev/mapper/vgsys-lvopt 30G 25G 4.8G 84% /opt /dev/sda1 226M 71M 144M 34% /boot

And the result of the polling via snmp from my nagios poller:

 # ./check_snmp_storage.pl -H 172.x.x.x -v 1 -C public -m tmpfs -w 80 -c 90
Filter : tmpfs
OID : 1.3.6.1.2.1.25.2.3.1.3.8, Desc : Shared memory
OID : 1.3.6.1.2.1.25.2.3.1.3.35, Desc : /opt
OID : 1.3.6.1.2.1.25.2.3.1.3.6, Desc : Memory buffers
OID : 1.3.6.1.2.1.25.2.3.1.3.1, Desc : Physical memory
OID : 1.3.6.1.2.1.25.2.3.1.3.33, Desc : /dev
OID : 1.3.6.1.2.1.25.2.3.1.3.32, Desc : /sys/fs/fuse/connections
OID : 1.3.6.1.2.1.25.2.3.1.3.36, Desc : /boot
OID : 1.3.6.1.2.1.25.2.3.1.3.7, Desc : Cached memory
OID : 1.3.6.1.2.1.25.2.3.1.3.3, Desc : Virtual memory
OID : 1.3.6.1.2.1.25.2.3.1.3.10, Desc : Swap space
OID : 1.3.6.1.2.1.25.2.3.1.3.31, Desc : /
storages selected : 0
Unknown storage : tmpfs : ERROR

As you can see, the tmpfs filesystems are not showed in SNMP. (but I tried without hope (neither success) "-m tmp", "-m /tmp")

Is it possible ?

Someone know a plugin to monitor a tmpfs filesystem ?

Thanks

up vote 1 down vote accepted

This isn't the fault of check_snmp_storage.pl. Oddly, the hrStorage branch includes types for "RamDisk" (hrStorageTypes 8), but an snmpwalk confirms what you are seeing: it ignores tmpfs mounts.

According to the usage documentation, you can explicitly (try to) force the script to check RamDisk storage using -q RamDisk.

You can use the standard check_disk plugin with the NRPE agent to check tmpfs mounts, though.

  • Keith, ./check_snmp_storage.pl -C public -H 172.x.x.x -w 1 -c 2 -v -q RamDisk -m * doesn't output the RamDisk. If you tried with snmpwalk, I guess it isn't possible without agent. I'll try with NRPE. Thanks – Brice Jun 6 '14 at 9:51

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.