10

I have a laser printer (Samsung ML-2010) that is in good condition, it works in Windows and old linuxes, but not with my fresh installation of ArchLinux. The printer is recognised and configured, but not printing, saying about any job:

canceled at
Fri 06 Jun 2014 10:15:26 PM EEST 
"Filter failed"

The question is -- where to look at to find more? Cups logs don't seem to have anything related.

  • I got "filter failed" because the printer cable was unplugged. Error_log was off course empty. – niels kristian schmidt Feb 1 at 0:18
7

For Ubuntu 14.04 users (and maybe others) you cannot add the foomatic-filters as suggested above, as they conflict with the CUPS project's version (cups-filters).

The hint may be in /var/log/cups/error_log. In my case, the output looks like this

[17/Aug/2014:12:47:31 +1000] [Job 83] JCL: 12345X@PJL 
[17/Aug/2014:12:47:31 +1000] [Job 83] <job data> 
[17/Aug/2014:12:47:31 +1000] [Job 83] sh: 1: hpijs: not found 
[17/Aug/2014:12:47:31 +1000] [Job 83] GPL Ghostscript 9.10: Can't start ijs server "hpijs" 
[17/Aug/2014:12:47:31 +1000] [Job 83] renderer exited with status 1 
[17/Aug/2014:12:47:31 +1000] [Job 83] Possible error on renderer command line or PostScript error. Check options.Kid3 exit status: 3

It can be solved with:

sudo apt-get install hpijs-ppds printer-driver-hpijs

Not sure if both are needed, I just picked all hpijs-like things in Aptitude.

  • This advice is very helpful in my case. I ran into the same problem but the actual reason, which I figured from the log, is that I accidentally uninstalled ghostscript. – qweruiop Nov 30 '15 at 20:05
  • Thanks, my log gave me the answer, I was trying to print only 2 pages of 20, reversed and only even pages. But it didn't like that for some reason and gave me the filter failed. I didn't realize that selecting options like reverse, odd pages or a range were considered filters. – Elijah Lynn Mar 5 '17 at 19:10
5

Since this is a top hit on Google for "debian jessie filter failed" I'm going to add what helped for me.

This is for Debian Jessie and CUPS failing with "filter failed"!

The culprit was the ghostscript package from stable (i.e. Jessie in this case) which crashes a lot. I upgraded to the ghostscript package from testing.

2

Try installing foomatic-filters and foomatic-db-engine from AUR.

1

I had the same problem on Debian Jessie!
The tip of Erik Winkels solved the problem.

I modificated the /etc/apt/sources.list
- Added the line: deb http://ftp.at.debian.org/debian/ sid main

Then I followed the steps:
- sudo aptitude update
- sudo aptitude safe-upgrade ghostscript
- Revert the sources.list, and again:
- sudo aptitude update

Now my ghostscript is in Version 9.19~dfsg-3, and printing works.

1

For the benefit of anyone seeing this error message in 2019, a possible cause is an incompatibility between older versions of cups-filters and recent versions of ghostscript. Upgrading the former or downgrading the latter resolves the issue.

0

I had a similar "Filter failed" error message with a HP CP1217 printer, the steps on this page (https://ramblingmoose.wordpress.com/2018/04/18/debian-and-raspbian-installing-a-cups-print-server-and-a-proprietary-p1102w-print-driver-on-linux/) helped me, I'll quote the relevant bit:

I ran in terminal: sudo hp-setup -i

For installing plug-in the prompts I answered were

  • 0 (zero) for USB printer
  • d for download – download had error "Unable to receive key from Keyserver"
  • y to install Yes to accept the EULA
  • y to agree that "this PPD file appears to be the correct one"
  • Enter a location description
  • Entered through "additional information for this printer"
  • y to print a test page

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.