1

When an LDAP user logs into the system they have incorrect permissions to their home directory.

LDAP and NFS services exist on the same server.

The directory shows the correct ownership / permissions:

drwx------. 4 ldaptest ldaptest 4096 Jun  9  2014 ldaptest

however the UID / GID do not match those on the server

client:

bash-4.1$ id
uid=10001(ldaptest) gid=10001(ldaptest) groups=10001(ldaptest)     context=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023

server:

[root@ldap1 log]# id ldaptest
uid=502(ldaptest) gid=502(ldaptest) groups=502(ldaptest)

How do I resolve this?

  • I have not tested this solution in Linux, but try using inherited permissions on the sub directories: superuser.com/questions/151911/… – Mike Soule Jun 9 '14 at 15:34
  • 1
    Funny, I found the fix right after I posted the question. The local user account ldaptest on the server had different UID / GID than what was in the LDAP DB. That's why there was a mismatch on the client as well. I changed the UID/GID on the ldaptest@server account and now it works. The account must have been created incorrectly during the migration step of setting up LDAP. (migrate_common.ph) – noobishguy Jun 9 '14 at 17:17
0

Set up LDAP idmap on the server like you have on the workstations. Or add it to all. Use the same UID config method and settings.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.