2

The address of our company www has been changed from IP.OLD to IP.NEW some 10 days ago. All public DNS servers incl. that of our ISP do reflect this change.

Our DNS server running at Windows Server 2012 stubbornly translates to IP.OLD.

Here are all steps I tried:

  • ipconfig /flushdns (at server)
  • DNS Manager - Action - Clear Cache / Update Server Data Files / Scavenge Stale Resource Records... Restart
  • Properties - Forwarders: change their order, restart DNS... (Note: There are two of them, both translate to IP.NEW correctly.)
  • Checked there are no Conditional Forwarders etc.

Is there any way to force this DNS server to translate the address to IP.NEW?

  • If you already flushed your DNS server's cache, the issue is likely with your forwarders. Try removing them and relying on root hints instead, then see what your local DNS server resolves it to. – ThatGraemeGuy Jun 10 '14 at 7:07
  • @ThatGraemeGuy: I did as you suggested (removed both forwarders, flush, restart...) and still IP.OLD. I also tried to uncheck "Use root hints if no forwarders are available" as another attempt and again, nothing changed. There is no problem with those forwarders. If I set them as DNS server in a workstation, they translate to IP.NEW. – user681768917 Jun 10 '14 at 7:33
  • Note: Adding a record to C:\Windows\System32\Drivers\etc\hosts to translate to IP.NEW helps for the server machine itself, not for its DNS functionality, so it's no workaround. – user681768917 Jun 10 '14 at 7:53
  • is your local DNS server authoritative for your domain? – Dusan Bajic Jun 10 '14 at 7:59
  • @dusan.bajic: I've read some definitions what does "authoritative DNS server" mean and I'm not sure. We are rather a small company with only one domain and only one DNS server. There are two Forward Lookup Zones _msdcs.XXX.YY and XXX.YY in a DNS Manager tree, both running. – user681768917 Jun 10 '14 at 8:23
1

Your local DNS server is configured with xxx.yy zone, and will never query public DNS servers. Just edit the www.xxx.yy record directly from DNS Manager.

  • There was a WWW Host(A) OLD.IP static record which I overlooked. After editing it, XXX.YY resolves to NEW.IP. – user681768917 Jun 10 '14 at 10:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.