I am attempting to extend snmp to return number of a given process

This is the tool, saved at /usr/bin/count_proc.sh

ps aux | awk '
BEGIN { c=0 }
/processname$/ { c=c+1 }
END { print $c }'

in my snmpd.conf, I have the following line:

extend . count_proc /usr/bin/count_proc.sh

However, I am not able to retrieve the result of this command with this OID. When I run a snmp query for this OID, the result is:

Value: (Snmp No Such object)

If I run traverse the snmp tree, I finally see something, but its strange... "Next OID" is the name of my tool, and not numeric at all.

OID: .
Next OID: /usr/bin/count_proc.sh
Value: 1

And finally, I will see the value I am expecting.

OID: .
Value: 13

But this is not the OID I expected to query to find the output. I will also find the output on several other OIDs.

Is this working as intended, or am I missing something important here?

2 Answers 2


Personally I use extend without OID, like:

extend count_proc /usr/bin/count_proc.sh

The OID generated by snmp is simple, the result is:

The OID is :

Explanation : 10 : number of character in "count_proc" 99 : ASCII decimal value of 'c' 111 : ASCII decimal value of 'o' 117 : ASCII decimal value of 'u' 110 : ASCII decimal value of 'n' 116 : ASCII decimal value of 't' 95 : ASCII decimal value of '_' 112 : ASCII decimal value of 'p' 114 : ASCII decimal value of 'r' 111 : ASCII decimal value of 'o' 99 : ASCII decimal value of 'c'

So you can easily retrieve the OID programatically.


Probably This link can help you in "extend" naming convention


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.