0

In outlook the auto complete gets stored in *.NK2. Where does it store for OWA 2013 ?

Some people saying that it gets stored on exchange server within user email account. Is there

a way that I can make a copy of this file and put it back when users somehow lost their auto

complete address list? Some of our users are going crazy about losing their email address

cache. All they did was reset IE 10 and the OWA email address cache all gone. which means that

auto complete list is not stored on exchange server under user account?

3
  • 1
    In outlook the auto complete gets stored in *.NK2 - That is only true up to Outlook 2007. In Outlook 2010 and forward the autocomplete entries are stored in the Exchange mailbox (for Exchange users) or in the PST file (for non-Exchange users). For OWA 2010 and 2013 the autocomplete entries are stored in the mailbox just as they are for Outlook. OWA is simply another method of accessing the mailbox.
    – joeqwerty
    Jun 12 '14 at 13:13
  • can you provide more details. cuz all i can see in exchange 2013 is database which can not be read directly. so there is no way to tell which file is holding auto complete data......
    – Root Loop
    Jun 12 '14 at 17:50
  • 1
    The autocomplete entries are stored in a hidden message in the users mailbox. It is not a file in the file system on the Exchange Server. Yes, you cannot edit or view the data in the mailbox database directly, but you can use MFCMAPI to access the contents of the mailbox, including hidden messages. mfcmapi.codeplex.com/releases/view/118446
    – joeqwerty
    Jun 12 '14 at 18:03
1

The auto-complete data is stored directly on the users mailbox database (since exchange 2010).

I had the same problem with a single mailbox. I ended up having to migrate the entire user to a new mailbox (deleted and restored). However this is only on rare occasions.

Few things you can do that usually fix this.

  1. Move the effected users mailbox to different databases (this causes exchange to check mailbox integrity insisted of waiting).
  2. Have the user login to there account via Outlook. In outlook go to File --> Options --> Send Messages --> Empty Auto-Complete List. After you do that wait 2 minute to make sure that outlook sync that change to exchange.

Make sure that works by restarting the outlook client and seeing if it fixed the problem.

If that didn't work your best bet is to initiate a complete mailbox export request via exchange powershell and delete the account. Recreate immediately and re-import data you exported.

Note: When you do this, it will cause everyone's auto-complete for that user you recreated to not work until they re-add the user from the address book or delete that user from auto-complete (price you pay).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.