I've updated a SuperMicro X7SPA-HF-D525 to IPMI firmware version 3.12.

I've tried setting the MAC address with the BIOS, ipmicfg and ipnmac.

Is there a fix for this?

  • I'm sorry - what exactly are you trying to fix? – Felix Frank Jun 13 '14 at 21:29
  • It's not going to have much luck getting on the network, with a MAC like that, especially if there are a few of them like this. I'm reminded of a similar Intel bug some time ago for desktop NICs. – Falcon Momot Jun 13 '14 at 22:02
  • 1
    Because: Supermicro – ewwhite Jun 13 '14 at 22:30
  • I'm trying to fix the fact that the MAC address is just a bunch of zeros instead of the original after I updated to the version support gave me – Maxim Van Damme Jun 14 '14 at 20:35

You can set the IPMI NIC MAC address with the ipmitool utility (http://ipmiutil.sourceforge.net/) available for Linux (rpm/deb), Windows, Solaris and FreeBSD here: http://ipmiutil.sourceforge.net/FILES/

The following command will set the MAC address:

ipmitool lan set <channel number> macaddr <xx:xx:xx:xx:xx:xx>

In my case, the IPMI NIC's MAC address had been zeroed out (reason unknown). The MAC address of what it was supposed to be was a sticker on the motherboard. However, during my limited testing, I was able to set the MAC address to anything and that was good enough for IPMI to work properly.


This was a bug in the IPMI firmware and is fixed in version 3.16 and up. Changelog: "[X7SPA] Fix the issue that LAN connection is not working."


I encountered this issue today on a different board (X8DTU).

Symptoms: When logging into the IPMI web interface after the upgrade, the system MAC addresses were reported as 00:00:00:00:00:00 and 00:00:00:00:00:01.

For me, the solution was to shutdown the server and remove power for 30 seconds. When power was restored and the BMC/IPMI board booted, the correct MAC addresses were shown again.

Alternatively, you may be able to reset the configuration of the board using ipmicfg or another ipmi tool.

I was given the command below by SuperMicro support, although I didn't have to use it.

IPMICFG –RAW 0x30 0x41 

You can't usually change the builtin MAC address to an arbitrary value. If this happened after a firmware update I suggest that you call SuperMicro's support and complain at them.

It is likely ignoring your input MAC because it's not a LAA. If you use a LAA for it, you might have some success. LAAs are those MAC addresses for which the twos bit in the first octet is set (e.g. 02:00:00:01:02:03), and for which the OUI is not enforced (and also the interface-specific part, effectively an ESN, is not enforced).

See What range of MAC addresses can I safely use for my virtual machines?.

Assigning LAAs is a workaround, but good luck dealing with supermicro for a real fix.

  • I tried using one of those MAC addressed but it also didn't work – Maxim Van Damme Jun 14 '14 at 20:42
  • Bad firmware then. – Falcon Momot Jun 15 '14 at 11:41

I've updated a SuperMicro X7SPA-HF-D525 to IPMI firmware version 3.12.

According to the Motherboard product page at http://www.supermicro.com/products/motherboard/ATOM/ICH9/X7SPA-HF-D525.cfm , you want "Firmware Revision: R 2.67". Are you sure you flashed the right firmware? Note that some of the X7 motherboards aren't smart enough to stop you if you are flashing the wrong firmware.

A few of my Supermicro systems with X9 motherboards needed a BIOS update before the IPMI Firmware update. This was according to the BIOS and IPMI Firmware changelogs, and I didn't test what would happen if I didn't flash the BIOS first.

  • I've updated it to version 3.12 becuse 2.67 had an bug and when I contacted support about it they said to update it to version 3.12 – Maxim Van Damme Jun 14 '14 at 20:33
  • I see. In that case, follow the suggestions of Supermicro support. However since you might be using a beta-release (Or at least, a non-production release) and we may not be able to help you. You might need to contact Supermicro support again; and make sure they provide you with the changelog for the firmware. – Stefan Lasiewski Jun 14 '14 at 21:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.