I'm attempting to configure SMTPS in Virtualmin and am running into a roadblock. I followed the instructions here without a problem but when I do the autoconfigure in Thunderbird it still says that the outgoing mail is unencrypted.

The steps I took (outlined in the link above) are that I added SMTP to the virtual server through Edit Virtual Server and then copied the SSL certificate over to Postfix via Manage SSL Certificates. I restarted the whole server for good measure as well. Might I be leaving something out?

I suppose I could try doing the manual configure in my email client (in case autoconfigure isn't picking up on the encryption), but I don't know what the proper outgoing parameters are for the manual configuration with regard to SSL and Authentication.

Any thoughts would be appreciated.


After following the instructions here, as mentioned above, I changed my autoconfig server template under System Settings > Server Templates (and under the dropdown menu "Edit template section") > Mail client auto-configuration. In the section Thunderbird auto-configuration XML, under the heading outgoingServer, I changed the port from $SMTP_PORT to $SMTPS_Port and selected XMLtemplate below as opposed to Automatically generated. My XML template is therefore as follows:

<?xml version="1.0" encoding="UTF-8"?>

<clientConfig version="1.1">
  <emailProvider id="$SMTP_DOMAIN">
    <displayName>$OWNER Email</displayName>
    <incomingServer type="imap">
    <outgoingServer type="smtp">

If the variable $SMTPS_Port doesn't work for you, you can try manually entering port 465. If you have any other issues, I'd recommend this VirtualMin forum post where I got the answer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.