0

I have installed the Windows Deployment Service as a role on our main Domain Controller, which also has the File Services and DHCP Roles installed on it.

During a routine maintenance update for Windows Updates, our machine (A VM) was restarted, but the Windows Deployment Service did not start up.

After some digging through the event log, I found that the error was caused by not being able to properly initialize a RPC server on port 5040 for our machine. Further looking into the event log shows that the RPC error is because of a duplicate endpoint. Searching for this issue hasn't turned anything up, and because our domain controller is in production I'm hesitant to restart the machine, which I figure would just clear up the RPC issues.

For the time being, I've set the WDS service to a delayed start, and the permissions on the Domain Controller are appropriate with cross checking Technet and other forums. DHCP Option 60 and 67 are enabled as recommended too, and were initially enabled.

Nothing has changed in our company's machine image. If all else fails I can just deploy via USB.


The service will not start manually. Here are the 3 separate Event Logs for the attempt:

The Windows Deployment Services Server service terminated with service-specific error The endpoint is a duplicate..

Event ID 7024


An error occurred while trying to start the Windows Deployment Services server.

Error Information: 0x6CC

Event ID 257


An error occurred while trying to initialize the RPC server on port 5040.

Error Information: 0x6CC

Event ID 1024

13
  • 4
    I have installed the Windows Deployment Service as a role on our main Domain Controller wat
    – tombull89
    Jun 16 '14 at 13:37
  • In Server 2008 R2 you can add roles for your server. Windows Deployment Services is one of these roles. The server that I installed the role on also happens to be a domain controller.
    – user226513
    Jun 16 '14 at 13:47
  • 4
    Yes, I know you can. Domain controllers are normally expected to be just domain controllers.
    – tombull89
    Jun 16 '14 at 13:52
  • Windows Firewall woes? Jun 16 '14 at 14:03
  • 2
    Unfortunately due to how my company doesn't wish to pay for an appropriate IT infrastructure, that is what I have to work with.
    – user226513
    Jun 16 '14 at 14:03
0

Did you check the option "Do not listen on DHCP ports"?

Also did you check the box that says: Configure DHCP options to indecate that this is a DHCP server?

All of these options are in WDS server properties under:DHCP

That is what worked for me.

1
  • Sorry I did not read the comments. The same answer is in there... :-P Jul 4 '14 at 22:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.