12

I am trying to upgrade the iDRAC on my PowerEdge R710 but am unable to login to the Web Interface.

After I enter the admin login and password in the web UI, it thinks about it for a while, and returns me back to the login screen.

I am able to connect through SSH though. I've already tried resetting the iDRAC and changing the admin password.

The RAC log (racadm getraclog) seems to show a successful login.

iDRAC 6 on a PowerEdge R710

  • 2
    What does Dell have to say? – joeqwerty Jun 16 '14 at 14:10
  • 7
    Tried a different browser or from a different client? The number of times I've seen those kind of login loops result from a client-side SNAFU is staggering. – HopelessN00b Jun 16 '14 at 14:14
  • Also, if there are too many log in attempts with a false password, iDRACs will block people from logging without telling them for what seems to be an undocumented amount of time.... – Kyle Brandt Jun 16 '14 at 21:10
  • It's not this issue, regarding browser language and old firmware, is it? serverfault.com/questions/560883/… – mfinni Jun 16 '14 at 21:16
14

Have you tried looking at the iDRAC6 troubleshooting guide? They have a whole section of things to try for logon loops

Continual Loop

(Normally noticed when customer is trying to log into GUI Page).

  1. Ensure customer is using a supported Browser

  2. If customer has changed browser settings, reset to defaults and check.

  3. Clear the browser cache and browser cookies and restart the browser.

  4. Check the security settings of browser and the host operating system. Check the firewall settings to verify firewall is not blocking iDRAC network traffic

  5. Reset iDRAC

  6. Update FW/SW

  7. Try draining flea power by unplugging the server from power source and then holding power button down for 20 seconds

  8. Do an iDRAC reset to default using any of the following:

    a) racadm racresetcfg (No host reboot required)

    b) During POST enter CTRL+E option and execute Reset to default (Host reboot is required )

  9. After reset to default is completed, reconfigure iDRAC settings (LAN config, IPMI over LAN etc.)

  10. Replace parts

I've gotten these login loops before and usually the first 4 steps are enough to get me connected normally again. Usually, (assuming you haven't made changes to your browser) I start on step 3 and clear cache/cookies and can connect again about 90% of the time.

  • 1
    It was the browser cookies that did it for me... – thermans Jun 17 '14 at 16:34
3

I had this same problem on Firefox on Linux with iDrac6 after a FW upgrade to v2.90. It worked in Incognito mode but in normal mode kept looping back to the login screen. Clearing the web cache (not cookies) resolved the issue for me.

  • clearing the cache resolved for me – ravi.zombie Apr 3 at 7:33
0

Just had this issue in IE 11. Set compatibity mode and used the IP address instead of the hostname and was able to get in. Console would not open though, had to change console settings to Java. Good luck

0

I just ran into a similar issue- If I used a DNS name for the iDrac, then i'd get the login loop, and eventually use all 4 sessions and get locked out. Using the IP Address allowed me to login, and then upgrading the firmware from 1.51.51.51 to 2.21.21.21 resolved the issue entirely.

0

If you don't want to go to the trouble of resetting all of your browser's cookies, you can try opening an incognito/private browser session.

0

I had to use IP address in order to login. Once I used IP address instead of FQDN, no problem. Upgrading from version 1.5x to 2.5 solved the problem. Can not believe that Dell would release something like that even in early version.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.