0

I try to get allow header form apache server. I sended request with curl. The server return headers but not "header allow" header:

$ curl -v -X OPTIONS 10.0.0.1
* Rebuilt URL to: 10.0.0.1/
* Hostname was NOT found in DNS cache
*   Trying 10.0.0.1...
* Connected to 10.0.0.1 (10.0.0.1) port 80 (#0)
> OPTIONS / HTTP/1.1
> User-Agent: curl/7.37.0
> Host: 10.0.0.1
    > Accept: */*
> 
< HTTP/1.1 200 OK
< Date: Sun, 15 Jun 2014 07:35:24 GMT
* Server Apache/2.2.22 (Ubuntu) is not blacklisted
    < Server: Apache/2.2.22 (Ubuntu)
< X-Powered-By: PHP/5.3.10-1ubuntu3.7
< Vary: Accept-Encoding
< Content-Length: 1498
< Content-Type: text/html
< 

I not find options to set the headers.

1 Answer 1

0

I was able to add the Allow header manually within a Virtual-Host stanza:

<VirtualHost ...>
...
Allow: GET,POST,PUT,DELETE,OPTIONS
...
</VirtualHost>

From Chrome Developer Tools:

...
Allow:GET, POST, PUT, DELETE, OPTIONS
...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .