6

The freetds.log file was overloading the system, so I changed the debug flags in /etc/freetds.conf :

    ;       dump file = /tmp/freetds.log
    #;      debug flags = 0xffff
    ;       debug flags = 0x80

How do I restart freetds or unixodbc? Nothing is taking effect, even when I comment out the dump file = /tmp/freetds.log line.

3 Answers 3

5

There doesn't seem to be anyone who knows, but I figured it out.

So it is automatic. If it doesn't look like your changes have taken effect, it is because you are editing the wrong file. I had 2 freetds.conf files in different locations. Do a locate freetds.conf and you'll see that you have multiple results.

0

In my own experience I found that changes to the freetds.conf file were not applied until I actually rebooted the machine itself.

I had simply changed the log file location and the debug level, but only once the server was rebooted did I see these changes being taken into account.

Prior to rebooting the server (which was done because nothing else I tried seemed to work) I tried to restart the various services which I though would impact, namely nginx, but this did not have any effect.

0

Old thread, i know. But it has no accepted answer yet and hopefully this could add some value. :)

Using Freetds as part of PHP development (with nginx etc) we need to restart PHP FPM for the changes to come into effect.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.