I have a Windows 2008R2 server that is a member of a domain. The other day I found that its time was different from the domain controller by seven seconds. I ran the following command...

w32tm /config /syncfromflags:domhier /update

net stop w32time

net start w32time

I then rebooted the server just to be sure. The time on the server was 'correct' in no time. But a day or two later the server has drifted again by 3 seconds.

All other member servers on this domain are fine (time is in sync to well within a second)

I've checked the settings in regedit and the 'Type' key shows 'NT4DS' which I believe is correct for a server synced from the domain. All other registry entries under that folder match a working server.

I believe all the correct ports are open between the server and the domain. The server has no other domain related problems.

The server is virtual (VMware). The virtual machine is not set to sync time with the host. Most of the other servers (that don't have this problem) are also virtual, on the same host pair.

Any ideas? Or any further areas I can check to verify the config?

Edit: New information. I just ran w32tm /query /status and got this...

Leap Indicator: 3(last minute has 61 seconds)

Stratum: 0 (unspecified)

Precision: -6 (15.625ms per tick)

Root Delay: 0.0000000s

Root Dispersion: 0.0000000s

ReferenceId: 0x00000000 (unspecified)

Last Successful Sync Time: unspecified

Source: Free-running System Clock

Poll Interval: 10 (1024s)

On a different server the 'Source' paramater lists a domain controller. So there is definitely a 'good' reason for this server to have the problem. I will investigate this myself but providing it here for the benifit of those following this question.

Edit to provide screenshot of time synchronization task history...

enter image description here

  • What is the value of the SpecialPollInterval when executing Get-Item HKLM:\SYSTEM\CurrentControlSet\Services\W32Time\TimeProviders\NtpClient? – Daniel Jun 20 '14 at 9:47
  • Please also show us the history of the SynchronizeTime task (\Microsoft\Windows\Time Synchronization\SynchronizeTime) – Daniel Jun 20 '14 at 9:52
  • SpecialPollInterval 3600 (or 0x0000e10) There is no 'TimeSynchronization' folder under '\Microsoft\Windows' Are you refering to the registry still? – MrVimes Jun 20 '14 at 9:58
  • No, to the task. – Daniel Jun 20 '14 at 10:00

"Free-running System" or "Local CMOS Clock" = not synchronizing with the domain hierarchy. You may want to enable w32tm debug logging to get more information. Also check the domain controller it is synchronizing with, if it is having a w32tm issue/not advertising, it will not be able to sync clients.

w32tm /debug /enable /file:c:\Windows\debug\w32time.log /size:10000000 /entries:0-116  

Enable Windows Time Service Debug Logging


The Windows Time Service wasn't designed nor intended for such accuracy.



  • It's difficult to accept this. In all the years and on all the virtual machines I look after, the time has never drifted by more than a second on correctly configured machines, until this one. – MrVimes Jun 20 '14 at 10:44
  • It may be difficult to accept, but based on my understanding of the Windows Time Service, and according to the links I provided, that is the way it is. You can jump through however many hoops you like to "resolve" it but the fact is that it wasn't designed or intended to be as accurate as you or I would like it to be. – joeqwerty Jun 20 '14 at 10:48
  • So there must be something else at play here. I am not saying you are incorrect. I am asking why this isn't a problem for the many other vms I've looked after for years. – MrVimes Jun 20 '14 at 10:56
  • I just ran w32tm /query /status and I get 'Free running clock' for the source, whereas I get a domain controller's hostname when I run this command on other servers. – MrVimes Jun 20 '14 at 11:05
  • I'm neither correct or incorrect. I'm simply passing on the information from Microsoft, as shown in the two links in my answer. – joeqwerty Jun 20 '14 at 21:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.