-2

I've been playing with my C: drive permissions and I have managed to mess them up. Now when I log in nothing appears and I can't launch anything. I tried safe mode and the same thing happens with that.

I can't even launch cmd.exe and it says that "I don't have the permissions" even though I am the admin.

I tried to use the command prompt in repair mode but when I choose the language it says the Parameter is incorrect and then restarts.

I have a Windows Server 2008 R2 with AD installed on it. What should I do?

4

You should restore your server from your latest backup.

  • tnx but i dont have a backup – KababChi Jun 20 '14 at 12:37
  • 4
    Then you are in trouble. Start rebuilding. – MDMarra Jun 20 '14 at 12:37
  • 1
    don't use the b-word!!! – the-wabbit Jun 20 '14 at 12:38
1

I missed the bit on "I cannot launch cmd.exe". So this is not going to help you.

you could try icacls.exe with the /reset switch from the root of c:

cd /d c:
icacls * /t/ /q /c /reset

the /t switch if for recursively change permsisions. The /q is for quiet, the /c is to continue on errors.

you may have to take ownership of the files first

takeown /R /F *
  • 2
    /reset only removes implicit entries and replaces them with inheritable entries. It sounds like the OP broke permissions at the root of the volume, so this likely won't help. – MDMarra Jun 20 '14 at 12:41
0

You could try:

  1. Boot your server off the install CD.
  2. Choose Repair.
  3. Launch a command line and try natxo asenjo's answer.

It might not help, for the reason MDMarra specified in his comment, but it's worth a try.

Not the answer you're looking for? Browse other questions tagged or ask your own question.