I got a server with windows server 2012; however, I was unable to run svc files with it. I was able to run asmx files on it. I decided I wanted to figure out how to run svc files. I tried the the contents of this link : http://msdn.microsoft.com/en-us/library/ms732012(v=vs.110).aspx

However, that did not fix my problem. I decided to also attempt to use aspnet_regiis.exe i; however, I got a error so that now my asmx files were not working.

After about 5 hours of googling and tried to figure this out, I tried to uninstall .net from the server and I reinstalled it (http://blogs.technet.com/b/askcore/archive/2014/04/24/removing-net-framework-4-5-4-5-1-removes-windows-2012-2012r2-ui-and-other-features.aspx) in hopes that it would go back to how it was originally.

That failed for me. So now I went to this link to use the graphical interface for this (which is what I tried first) https://stackoverflow.com/questions/14495429/alternative-for-the-registering-asp-net-4-5-on-windows-server-2012

but when I try to follow his step I get this error : enter image description here

Edit : For clarification this put me in a recursive loop where it would give me this message and as soon as I restarted it would give me this message again. https://www.jrssite.com/wordpress/?p=191

Upon closer inspection, I have the following errors:

  1. Unable to install counter strings because the SYSTEM\CurrentControlSet\Services\ASP.NET_64_2.0.50727\Performance key could not be opened or accessed. The first DWORD in the Data section contains the Win32 error code.
  2. Installing the performance counter strings for service ASP.NET_64_2.0.50727 (ASP.NET_64_2.0.50727) failed. The first DWORD in the Data section contains the error code.

Well I then decide to check the register which has ASP.NET without the 64 suffix. So I decide to try adding the keys myself using lodctl. (http://blogs.msdn.com/b/tom/archive/2008/04/11/asp-net-performance-counters-missing.aspx)

Basically, nothing works and I'm thoroughly stumped. All I want is my svc files and my asmx files to be visible from the web. Any help would be appreciated.

  • 2
    YOu need to install "HTTP Activation" for WCF to work (.svc) – MichelZ Jun 20 '14 at 13:22
  • 1
    When you uninstalled you most likely whacked the UI bits you were trying to use. Reinstall from the offline installer: microsoft.com/en-us/download/details.aspx?id=40779. – squillman Jun 20 '14 at 13:23
  • @MichelZ;@squillman I tried to activate http activation; however, when I try to activate it it puts me into a loop where I need to keep restarting. I'm trying the offline installer right now. – Aelphaeis Jun 20 '14 at 13:54

I think you will want to reinstall IIS completely, then when you are installing the web server features, be sure to enable WCF Services | HTTP Activation as @Michelz pointed out.

WCF Services | HTTP Activation

  • For those of you curious. I uninstalled everything except the bare bones OS and then re-installed everything and it all got sorted out. I enabled http activation and it worked. – Aelphaeis Jun 20 '14 at 14:54

The above worked for me BUT DO NOT REBOOT WINDOWS SERVER 2012. (Black screen of death). Uninstall and reinstall the same time.

Wait for pending reboot icon....

Then uninstall and wait then add everything back in including http activation. Do not reboot!

Walk away for 1 hr.

Computer may roll back some failed updates but don't worry just stay away from computer.

Eventually everything works!

Make fresh backup!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.