I have a scheduled task that I am trying to run a program (a DB backup program). For reasons unknown I am unable to actually get the program to run, even though the task log says everything was run complete on schedule.

What am I doing wrong? I've changed settings, used a UNC path to the program, tried different admin accounts, used the NETWORK SERVICE account. No success. Seems like it has to do with security permissions to run the program, but I can't solve it.

Can someone help figure out how to run this program from Task Scheduler? Thank you!

-OS: Server 2012 R2
-If I run the task while logged in (manually or on schedule while logged in), everything runs fine.
-The DB Backup Program has a log, but nothing in the log states anything even started when the task runs logged out.
-The DB Backup Program does not have a UI.
-The DB Back Program is intended to be run by the task scheduler and is run by other users around country successfully.
-The user set to run the task is a admin with full admin credentials. The task was also attempted to be run by the local built-in admin with no result.
-The program, folder and parent folders all allow permission to the admin group.

User: Admin Account
Run whether user is logged on or not
Run with highest privilages
Configure for: Vista, Server 2008
Daily, 3am, Enabled
Start a program: "C:\Program Files (x86)\Rock Gym Pro\Backup.exe"
Start the task only if the computer is on AC Power
Stop if the computer switches to batter power
Allow the task to be run on demand
Stop if the task runs longer than 3 days
If the running task does not end when requested, force it to stop
3:00AM - Task Scheduler launch task "\RGP Backup" , instance "C:\Program Files (x86)\Rock Gym Pro\Backup.exe" with process ID 3496.
3:00AM - Task Scheduler started "{206e1cd6-db27-49f7-b143-ca1228f59c74}" instance of the "\RGP Backup" task for user "DOMAIN\Admin".
3:00AM - Task Scheduler launched action "C:\Program Files (x86)\Rock Gym Pro\Backup.exe" in instance "{206e1cd6-db27-49f7-b143-ca1228f59c74}" of task "\RGP Backup".
3:00AM - Task Scheduler successfully completed task "\RGP Backup" , instance "{206e1cd6-db27-49f7-b143-ca1228f59c74}" , action "C:\Program Files (x86)\Rock Gym Pro\Backup.exe" with return code 0.
3:00AM - Task Scheduler successfully finished "{206e1cd6-db27-49f7-b143-ca1228f59c74}" instance of the "\RGP Backup" task for user "DOMAIN\Admin".

  • 1
    Did you give the Admin Account (that you describe above) "log on as a batch" and "log on locally" rights? – Brad Bouchard Jun 20 '14 at 22:28
  • The Default Domain Controller GPO Policy is active and has both "Allow Log On Locally" and "Log On as Batch Job" include the BUILTIN\Administrators security group, which the Admin account is a member of. – Edgeworks Jun 20 '14 at 23:20
  • Still searching for an answer. Right now I am running this task with the admin always logged in (machine locked) so that it can run daily. It won't run unless I am logged in. – Edgeworks Jun 27 '14 at 16:31
  • Sorry for the long hiatus. You mention the Default Domain Controller GPO, but unless this server that you're running the task on is a DC, then that won't apply to it; I'm assuming it is, but I have to check. So, if it's not a DC, create a new GPO that grants these rights to the user in question and scope it to the server in question and try again. Let me know when you get a chance to update/check. – Brad Bouchard Sep 16 '14 at 20:37
  • The server is our DC.--I did end up solving this by having the task start a different program that accomplishes the same task. The different program runs fine, so it is something with the Backup.exe program that does not work as expected under the task scheduler. – Edgeworks Dec 4 '14 at 23:21

i´ve been trying hard to make similar software run OK when you choose:

Run whether user is logged on or not

It resulted with 2 different software (SyncBack and synctoy) that the problems were in both cases third party soft related problems (not soft problems but things to take into account).

As an example, if you created a Task to run:

"C:\Program Files (x86)\Rock Gym Pro\Backup.exe"

as domain\user1 , With some parameters lik -R "MyBackup", but you configured the task from another user like domain\administrator,

and also set "parameters like -R "MyBackup"" as administrator, software creates "MyBackup" config file under administrator folders (usr/administrator/appdata/roaming/...), so when the task executes as doman\user1 , the program search for "Mybackup" config file in user1 folder.

As result, no file exist in user1 appdata or whatever folders, because you never configured the software from user1, so nothing happen.

To solve this, you have to logon as that user, in the server, in order the folders be created, test the script from that user (If you want with scheduled task, with the "Run whether user is logged on or not" option activated,), and then you configure the task from administrator user and then set to run as user1. That way when task run the software will find the "MyBackup" files and execute with no problem.

That was my problem, hard to find because there weren´t logs of this anywhere (or i couldn´t find them), just nothing happened when you run the task and finally says "Task Executed Successfuly".

Please let me know if i helped...Sorry my english im from Argentina.

  • Thank you. The task was setup under the server admin, to be run under the server admin. I did end up solving this by having the task start a different program that accomplishes the same task. The different program runs fine, so it is something with the Backup.exe program that does not work as expected under the task scheduler. – Edgeworks Dec 4 '14 at 23:26

I guess that the task is running in case there is a user logged in, and when you change the task options to 'run whenever there is a logged-on user or not', it does not.

The history logs show that the task is running, but you cannot see it running or interact the user-interface of the task, since it is set to run even if there is no user logged in.

Tasks that have user-interface should be set to run only in case a user is logged on. (Who will interact the user interface if there is no user logged in?)

Probably, this is not the answer you expect to receive :-(, but I hope it clarifies the issue.

  • Thank you for the info. The task does not have a user interface. I have run this task on another server before without issue (actually about 900 different companies run this task in a similar fashion). When I tried to run it on a Server 2012 machine, it says it runs, but will not unless I am logged in. It is a MySQL backup function that runs via a Backup.exe program that is intended to be run in the background at night via task scheduler. I'm at a loss as to why it won't run unless I leave the admin account logged in. – Edgeworks Sep 9 '14 at 23:14

I did end up solving with a workaround, though not a direct solution.

The program C:\Program Files (x86)\Rock Gym Pro\Backup.exe apparently is a program that actually starts the program C:\Program Files (x86)\Rock Gym Pro\RockGymPro.exe with the argument /backup

So instead of starting the action that didn't work:
Start a program: "C:\Program Files (x86)\Rock Gym Pro\Backup.exe"

My new action is:
Start a program: "C:\Program Files (x86)\Rock Gym Pro\RockGymPro.exe /backup"

Everything works fine now. No changes to any other settings or user accounts/pwds.


On the server running the script, DISABLE the Local Security Policy --> Security Options --> Network Access: Do not allow storage of passwords and credentials for network authentication

This allowed our Scheduled task to control services on the remote servers in the environment.


I Have the same issue. I schedule tasks using a fixed admin user. The issue doesn't show for all tasks and i'm not able to see a pattern. To have tasks starting regularely i worked around to let a RDP session open for the fixed admin user.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.